Webmin works Virtualmin not accessible

Hi, We have a server we’ve just upgraded, but the problem is that we can log in to the web GUI but only Webmin show. No Virtualmin access.

Operating system Ubuntu Linux 10.04.4
Webmin version 1.730

It has worked fine until update?


Did you by chance change the theme? If you change the theme away from the Virtualmin one, you’ll get more of a Webmin-only experience.

Best Regards, Peter Knowles TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com

It could be the theme, but I only have

Old Webmin Theme
Gray Framed Theme
Gray Framed Theme
Caldera Theme
Mxc. linux Theme

And I have tried them all. No luck.

Update Ive exported the Wirtualmib Framed Theme from other server, and installed. But this didn’t help.


Well, it’s odd that the theme would no longer be there… I’m curious what output this shows:

dpkg -l ‘webmin*’

That will show what Webmin/Virtualmin related packages are installed on your system.


Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name Version Description +++-===========================-===========================-====================================================================== ii webmin 1.730 web-based administration interface for Unix systems un webmin-adsl (no description available) un webmin-apache (no description available) un webmin-bandwidth (no description available) un webmin-bind (no description available) un webmin-burner (no description available) un webmin-cfengine (no description available) un webmin-cluster (no description available) un webmin-core (no description available) un webmin-cpan (no description available) un webmin-dhcpd (no description available) un webmin-exim (no description available) un webmin-exports (no description available) un webmin-fetchmail (no description available) un webmin-firewall (no description available) un webmin-freeswan (no description available) un webmin-frox (no description available) un webmin-fsdump (no description available) un webmin-grub (no description available) un webmin-heartbeat (no description available) un webmin-htaccess (no description available) un webmin-inetd (no description available) un webmin-jabber (no description available) un webmin-ldap-netgroups (no description available) un webmin-ldap-user-simple (no description available) un webmin-ldap-useradmin (no description available) un webmin-lilo (no description available) un webmin-logrotate (no description available) un webmin-lpadmin (no description available) un webmin-lvm (no description available) un webmin-mailboxes (no description available) un webmin-mon (no description available) un webmin-mysql (no description available) un webmin-nis (no description available) un webmin-openslp (no description available) un webmin-postfix (no description available) un webmin-postgresql (no description available) un webmin-ppp (no description available) un webmin-pptp-client (no description available) un webmin-pptp-server (no description available) un webmin-procmail (no description available) un webmin-proftpd (no description available) un webmin-pserver (no description available) un webmin-quota (no description available) un webmin-samba (no description available) un webmin-sarg (no description available) un webmin-security-updates (no description available) un webmin-sendmail (no description available) un webmin-shorewall (no description available) un webmin-slbackup (no description available) un webmin-smart-status (no description available) un webmin-snort (no description available) un webmin-software (no description available) un webmin-spamassassin (no description available) un webmin-squid (no description available) un webmin-sshd (no description available) un webmin-status (no description available) un webmin-stunnel (no description available) un webmin-updown (no description available) un webmin-usermin (no description available) un webmin-vgetty (no description available) un webmin-virtual-server (no description available) un webmin-virtual-server-theme (no description available) un webmin-virtualmin-awstats (no description available) un webmin-virtualmin-dav (no description available) un webmin-virtualmin-htpasswd (no description available) un webmin-virtualmin-mailman (no description available) un webmin-virtualmin-svn (no description available) un webmin-webalizer (no description available) un webmin-wuftpd (no description available) un webmin-wvdial (no description available) un webmin-xinetd (no description available)

No help here?


Hmm, it doesn’t actually appear that Virtualmin or any of the Virtualmin packages are installed at the moment.

Are all your other services working properly at the moment, it’s just that Virtualmin isn’t accessible?

And can you think of any other packages that may have been removed recently?

Lastly, what is the output of this command:

ls /etc/webmin/virtual-server/domains

All services seems to run fine. Only backup are not working which is not good.

Out :
121975713825942 123737997620341 125068077414046 1250849124267781 126529560713225 1277457371257061 1296821224257881 131520826612129
122103033715610 123797940319314 1250680782140461 125084984929258 1265295618132251 128281902121610 129795358131542 1315208290121291
122103034415610 1237979410193141 125068384526825 12508525188704 126563332725970 1282819035216101 1297953599315421 131608921824157
12211344551355 124083590816725 1250683854268251 125085252887041 1265633337259701 128324047324641 129924974132207 1316089258241571
12211344611355 1240835915167251 125068446030094 12520990124356 12698723348942 1283240496246411 1299249759322071 131722335518845
12211376723358 124539846525356 1250684468300941 125361138216793 126987234789421 12837821241744 130035668114935 1317223383188451
12211376783358 1245398473253561 1250685181589 1253611394167931 126987251810244 128378213817441 1300356698149351 13183327102521
12234686807090 12477547253851 12506851895891 125380217628928 1269872531102441 128577478428459 130277417022007 131833274425211
122641240426595 124775473238511 125077075913909 1253802187289281 127062492415073 1285774808284591 1302774191220071 131840940311670
122665329230615 124830296831550 1250770769139091 125665543624590 1270624933150731 128695985517449 13032076545393 1318409434116701
122665329930615 1248302976315501 12507753112378 1256655448245901 127287358719073 1286959865174491 130320767453931 132160329221065
122762412332242 12483431814634 125077532023781 125673481532442 1272873595190731 128696052620488 130812134029474 132160683013016
122907437717246 124834318846341 125084709916947 1256734830324421 127355269826358 1286960535204881 1308121362294741 1321606863130161
122907438417246 12505072021790 1250847107169471 12569052936160 1273552709263581 12874747161839 130933210228951 132161501329446
12313193576819 125050720917901 125084712416993 125690530561601 12752966075509 128747472618391 1309332126289511 1321615038294461
12313193646819 125051036012077 1250847133169931 125958696322248 127529662155091 128747953723943 13112557174870 132220920522162
12332264373368 1250510368120771 125084746119018 1259586973222481 12756409768970 1287479545239431 131296470413544 1322209230221621
12332264453368 12506781711891 1250847470190181 126019208914274 127564099789701 128835240226985 131359051225499 132739428620672
123598143222163 125067818018911 125084877725138 1260192100142741 127625136426453 1288352413269851 1313590542254991 1327394336206721
1235981440221631 12506794938126 1250848786251381 12635515267834 1276251394264531 129136522219168 1313656185722
12373799692034 125067950181261 125084911526778 126355153778341 127745735625706 129682120725788 13136562197221

Is it possible to reinstall virtualmin without harming the virtualservers ?


It looks like your Virtualmin config is still in-tact.

It may be as simple as just reinstalling all the Virtualmin-related packages.

Before doing anything else, I would suggest making a backup of your entire /etc directory.

Once you do that, try running this command on the command line as root:

apt-get install webmin-virtual-server webmin-virtual-server-theme webmin-virtualmin-awstats webmin-virtualmin-htpasswd webmin-virtualmin-svn

Then, run this command:

/etc/init.d/webmin restart

After doing that, you may then need to set the Webmin theme to use the Virtualmin Framed Theme.

Upon doing that, does Virtualmin begin working as expected?


Thx. When I run the apt-get install webmin-----

I get this :
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package webmin-virtual-server is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package webmin-virtual-server has no installation candidate

I have checked the sources.list and it seems fine, or I can not see what is missing.

deb http://archive.canonical.com/ubuntu lucid partner
deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
deb http://XXXXXXXX:XXXXXXXXXX@software.virtualmin.com/ubuntu/ virtualmin-lucid main # disabled on upgrade to lucid

Ive replaced the XXXX in the last line. :slight_smile:


Hmm, what output do you receive when running an “apt-get update”?

One thought that comes to mind is that if that particular Virtualmin license key is no longer valid (ie, if it expired), that could prevent it from being able to access the repository and reinstall it (note though that this wouldn’t be the cause of it being uninstalled, Virtualmin never disables working features or uninstalls itself).


The license should be valid according to my account here until 06-12-2015.

Apt-get install webmin says :

sudo apt-get install webmin
Reading package lists… Done
Building dependency tree
Reading state information… Done
webmin is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Ive tried to update to Ubuntu version 12 lts and it didnt change anything but diasble the virtualmin line in soucres.list . I have reactivated this and tried the

apt-get install webmin-virtual-server webmin-virtual-server-theme webmin-virtualmin-awstats webmin-virtualmin-htpasswd webmin-virtualmin-svn


Still comes with the missing candidate error E: Package ‘webmin-virtual-server’ has no installation candidate
E: Package ‘webmin-virtual-server-theme’ has no installation candidate
E: Package ‘webmin-virtualmin-awstats’ has no installation candidate
E: Package ‘webmin-virtualmin-htpasswd’ has no installation candidate
E: Package ‘webmin-virtualmin-svn’ has no installation candidate


Hmm, so what is the output of this command:

cat /etc/issue

I don’t see the virtualmin-universal repo in that repo list. That’s where everything Virtualmin related lives, except a couple of binary packages that are specific to that version of Ubuntu.

cat /etc/issue


Ubuntu 12.04.5 LTS \n \l

Okay, your distro is good – so I think we just need to add the universal repository to apt.

You can do that by editing your sources.list file, and add this line to it:

deb http://xxxx:xxxxx@software.virtualmin.com/ubuntu/ virtualmin-universal main

It dosent change much? When I run the apt-get install webmin-virtual-server webmin-virtual-server-theme webmin-virtualmin-awstats webmin-virtualmin-htpasswd webmin-virtualmin-svn

I still get the missing candidate error.


Did you by chance run “apt-get update” first? That would need to be run prior to the install, to get apt to notice the change to your sources.list.