Webmin/virtualmin url cannot use Let's Encrypt

Ubuntu 20.04
Webmin 1.973
virtualmin 6.16

Hello guys, can anyone help me pls:

after installing webmin/virtualmin and I created a default domain xyz.sld.tld:000000 with ssl (let’s encrypt)
it was working well.

But after creating a default virtual server called like the ip of the server to handle all non existing subdomains.

The webmin/virtualmin url xyz.sld.tld:000000 suddenly use the self signed ssl instead the Let’s encrypt one.

I tried to recreate ssl for webmin (over webmin configuration → ssl ) and in virtualmin (over server configuration → ssl) without luck, still use the self signed ssl.

the domain itself xyz.sld.tld has the right let’s encrypt ssl installed but not working for webmin/virtualmin url.

can somebody tell me how to fix it?
I hope it is clear enouth to understand. :wink:

thx for help

I don’t know what you mean by this.

You mean xyz.sld.tld:10000, right? Well, try admin.xyz.sld.tld to remove ambiguity about port, does this show the self-signed certificate too?

Thank you for your replay.

I try to be more precise:

Virtualmin → create virtual server and put as domain name the IP address of the server instead of a domain name

whyever it overrides the ssl coniguration for webmin as well.

I tried it but since i changed the port, it redirects me to xyz.sld.tld:10000 but the port is wrong how can i change it?

thank you for your help

any ideas? stil cannot find it out how to solve

You need a resolvable domain name. You can’t use an IP address as a domain name. Pretty much nothing will work when you do that.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.