Webmin/Virtualmin doesn't start any more after an update

Hi!

After an update I’ve made (from within webmin’s panel) Webmin/Virtualmin GPL fails to start. I don’t know what version was this, the last one, I’ve updated it a few days ago - I always do this when, in the webmin’s panel, a new update is available. So, now I restart the server but Webmin/Virtualmin is not starting.

My OS: Debian Linux 8

I do have access to SSH and when I try to start webmin with “/etc/init.d/webmin start” it says nothing, no error, just nothing.

Results after command “/etc/init.d/webmin restart”:

Stopping Webmin server in /usr/share/webmin
cat: /var/webmin/miniserv.pid: No such file or directory
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
Starting Webmin server in /usr/share/webmin
Failed to open SSL cert at /usr/share/webmin/miniserv.pl line 4412.

Any ideas?

Thanks!

Me too, 6 services down according to systemctl —failed and unable to start. No relevant log entries:
httpd
webmin
usermin
clamd@scan
dovecot
proftpd

I deleted some vhosts recently, thats the only change in some time!!

Centos7 with newest updates here

I have had the same issue. I was trying to update to webmin 1881 and my centos 6.9 system is not responsive and sshd didnt start either.
I dont know how to access the system as for some reason after reboot even webmin or sshd dont start.

There is a serious bug in webmin update tht need to be fixed. My earlier ver was i thnk 1871 or nearby of few months ago.

I have rebooted a few times n able to get sshd and restarted webmin service BUT browser does not open with webmin port

Hello Pls kindly help as I had to uninstall via yum and reinstall

it uninstalled
webmin noarch 1.881-1 @virtualmin-universal 76 M
Removing for dependencies:
wbm-virtual-server noarch 2:6.03.gpl-1 @virtualmin-universal 8.1 M

and at install
Installing:
webmin noarch 1.881-1 virtualmin-universal 27 M

it gave :
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Operating system is CentOS Linux
Installing : webmin-1.881-1.noarch 1/1
Webmin install complete. You can now login to https://abc.com:10000/

WHEN I try on browser it does not connect. When I do do service webmin status it shows webmin is stopped

Kindly help what can i do as I need to access the server??

Redhat/CentOS:
yum remove webmin
yum install webmin

After hours of wasting time I uninstalled and reinstalled using YUM and then what i did was
I edited /etc/webmin/miniserv.conf from SSL 1 to 0 and restarted webmin and now it worked Finally.
I also had to try this and in your case if you have any firewall just check if PORT 10000 is listening
iptables -A INPUT -p tcp -d 0/0 -s 0/0 --dport 10000 -j ACCEPT
service iptables save
/etc/init.d/iptables restart

Now i am running http instead of https but atleast i can access. IF you have SSHD server access via putty or securecrt etc. you can simply uninstall webmin and reinstall. That works.

I also got it to work again by editing /etc/webmin/miniserv.conf from SSL 1 to 0 and restarting Webmin. Now it works without SSL.

But there must be a solution to get it running again with SSL (https). No idea from the Virtualmin team?

I haven’t seen this behavior. The error just means Webmin is configured to use an SSL cert that doesn’t exist anymore, or doesn’t exist where Webmin is configured to find it.

The right thing is simply to disable SSL (temporarily) as Karl has suggested.

Definitely do not uninstall Webmin.

If you’re using Virtualmin, and you uninstall Webmin, you will likely also delete all of your virtualmin metadata (depending on which options you use). Unless you have a backup, you’ll have a really bad day. There is no reason to uninstall Webmin to solve this problem…it’s just a configuration issue.

Does anyone who has seen this issue remember if there were any other errors during the update?

Were you using a certificate generated by Virtualmin and then copied to Webmin? (using the “Copy to Webmin” or whatever it’s called, button in the Virtualmin SSL page)

There are a few ways to configure Webmin to use SSL, and knowing how y’all had SSL configured on your systems will help track down why the SSL config could break on update.

Hi Joe, thanks for your comment.

I remember that I changed something on the SSL configuration, there was something wrong with the SSL certs. Maybe I broke it by myself.

“Were you using a certificate generated by Virtualmin and then copied to Webmin? (using the “Copy to Webmin” or whatever it’s called, button in the Virtualmin SSL page)” --> as far as I remember: YES.

What can I do to reinstall the broken or missing SSL cert for Webmin?

Just copy the cert from Virtualmin to Webmin again. I still don’t actually know why it stopped working in either of y’all’s case…SSL in Webmin has always been robust for me. But, I would think giving it a new cert (or the same one) would Just Work.