Webmin Updates While Set To "Just Notify"

I have both package-updates and security-updates set to check daily and just notify. But the updates are getting installed as they come up (I don’t get a notification email that updates need to be installed, instead the updates get installed and I get notified of checksum changes by OSSEC.

I’ve tried deleting the cron jobs and re-creating them by setting to “just notify again”. The cron jobs are there “/etc/webmin/package-updates/update.pl” and “/etc/webmin/security-updates/update.pl”

Where do I check next to stop this? I really can’t have updates being installed automatically.

Webmin 1.690
Virtualmin 4.08.gpl GPL
CentOS 6.5

I found the culprit

/etc/rc.d/init.d/yum-cron status
Nightly yum update is enabled.

but i never touched yum-cron. is this something webmin installs?

thanks

Howdy,

Glad you figured it out!

I don’t believe Webmin/Virtuamin would install/enable that, I’m not quite sure why that would be installed.

I verified on some other CentOS systems here running Virtualmin that yum-cron isn’t installed.

-Eric