webmin update not signed, after update memory free is in TB

version webmin-1.620-1

I used yum update –nogpgcheck to do the upgrade since I got message not signed rpm, in CentOS 6.4.

After that I rebooted, then looked at Real memory 8589934592 TB total, wow, what an Upgrade, compared to the 3 GB I actually have, this makes me wonder, what is wrong here.

Reproduced on two machines using Virtualmin version 4.00 Pro.

I’m also getting “Package webmin-1.630-1.noarch.rpm is not signed … install failed!” and will hold off updating until the dust settles.


This should be fixed now. Try running yum clean all , then yum install webmin , and let us know if you are still seeing the signature error.

I show virtualmin-universal 1.630-1 installed now, so I guess it fix it for its key, but the same issue with memory, it shows I have almost unlimited memory (8589934592 TB total) on two different machines.

Same issue;

Your system has 8589934592 TB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.

I’m running Virtualmin GPL and Debian

An update to fix the problem is available here:


Running Processes 1.630 Fixes incorrect memory display on OpenVZ

Perfect, Thank You!!!

Any chance of it being an automatic update for anyone running more than one installations?

  1. Click on Webmin
  2. Click on Webmin Configuration
  3. Click on Webmin Modules
  4. Click on Install Module Standard module from www.webmin.com radio button, then … Click on proc - List, kill and renice running processes on your system; then Install Module.

Downloading http://download.webmin.com/download/modules/proc.wbm.gz (217.46 kB) .

The following modules have been successfully installed and added to your access control list
I rebooted, same issue.

Link on site is not the Same as above using Virtualmin;
but the file date on archive seem to be close, the file sizes are not.
so I clicked on Install Module From local file, picked file from above link given at webmin.com and rebooted, and it works.

My guess is that the proc.wbm.gz needs to be updated.

Hi Folks,

There were a few issues with the initial release of “webmin” to the repos… These issues were corrected by Joe, and all should work now correctly.

Just issue:

yum clean all yum update

If you are still having problems, please continue posting.

Best Regards, Peter Knowles TPN Solutions

E: pknowles@tpnsolutions.com
P: 604-782-9342
W: http://www.tpnsolutions.com

I still have this issue when installing a clean server.

Dependencies Resolved

 Package                 Arch                    Version                     Repository                           Size
 webmin                  noarch                  1.630-1                     cloudmin-universal                   21 M

Transaction Summary
Install       1 Package(s)

Total size: 21 M
Installed size: 57 M
Is this ok [y/N]: y
Downloading Packages:

Package webmin-1.630-1.noarch.rpm is not signed

I bypassed this issue by installing the rpm located here http://prdownloads.sourceforge.net/webadmin/webmin-1.630-1.noarch.rpm this rpm does not throw that error.

I am seeing:

Package webmin-1.630-1.noarch.rpm is not signed


yum clean all yum update

didn’t help.

Edit: I should add that this is happening on a Cloudmin server. Guest system have been upgraded without an issue.

Same here… all my servers updated OK apart from the one cloudmin is installed on. So the cloudmin-universal source is the one I get this issue.

I dont know if its related, but cant update any packages. In Virtualmin or command line with yum update, it runs through the whole update process, downloads, etc. but when I run yum update again, it still shows:

Transaction Summary

Install 13 Package(s)
Upgrade 233 Package(s)

Total size: 231 M
Is this ok [y/N]: y
Downloading Packages:

Package webmin-1.630-1.noarch.rpm is not signed
[root@office ~]#

To resolve this issue, please see http://virtualmin.com/node/27579

Installing it using rpm worked for me (I actually thought about that but didnt try it as it was for installation, wasnt sure if update would work).

Also, I had another issue in that yum update would not update anything, even though it went through the whole download and update process and said complete! But after updating webmin, yum update now works fine, and all my packages are up to date.