Webmin update confusion

We’re runing 3 Virtualmin (7.3.1-Pro) servers and there seems to be some confusion regarding how Webmin updates are handled.

One server shows a message on the Virtualmin dashboard:
" Warning!
Webmin version 2.010 is now available, but you are running version 2.001"

However when you click it to update, the process shows several errors, and the entire Virtualmin/Webmin becomes inaccessible with a Perl error until we roll back to a previous snapshot.
Undefined subroutine &main::authentic called at /usr/share/webmin/authentic-theme/index.cgi line 12”

The other two servers don’t show any updates available on the Dashboard even though they’re also running 2.001. In addition, those two servers don’t have an Upgrade Webmin button on the Webmin Configuration page either.

OS type and version Ubuntu 20.04
Webmin version 2.001


Have you installed the “webmin” repo perhaps on one of the servers? This would cause the server to pull in versions of Webmin which are NOT yet vetted for use with Virtualmin.

1 Like

Not as far as I’m aware. Virtualmin was installed using the official install.sh on all 3 servers.

The Virtualmin installer definitely would not have setup the Webmin repos, but I’m pretty sure the bug where Webmin would offer an unavailable version has been fixed…but maybe not so in 2.001.

But, you should make sure.

grep -r webmin /etc/apt/

If you have anything, you added the Webmin repos and shouldn’t have.

If you don’t see anything, apparently the bug is still not fixed, somehow.

Edit, to be clear: There is a reason we have not rolled out Webmin 2.010 to Virtualmin repos. You should not be running it. You would not see it in the usual circumstance, as far as I know. You had to either have forced an install from the github repo or have added the Webmin.com repo.

one of my servers upgraded to 2.010 but with no problems the other did not … I can not find an apt entry for webmin alone, but in my case webmin & virtualmin worked fine … maybe there is something missing from

Is it safe to upgrade to Webmin 2.010 or not yet?

It is not in our repos for a reason. “Safe” depends on your use case. 2.010 has bugs that effect Virtualmin, so it is not in our repos, but they are not going to blow up your server. 2.011 will be in the repos, soon, so maybe just wait a day or two or three.

I recommend you just assume we’re trying to provide the best Virtualmin experience we can, and use the Virtualmin repos for Webmin (and Usermin).


my “grep -r webmin /etc/apt/” shows:

/etc/apt/sources.liste:deb [arch=amd64] http://download.webmin.com/download/repository sarge contrib
Binary file /etc/apt/trusted.gpg matches
Binary file /etc/apt/trusted.gpg~ matches
/etc/apt/sources.list:deb http://download.webmin.com/download/repository sarge contrib
/etc/apt/sources.list:deb [arch=amd64] http://download.webmin.com/download/repository sarge contrib

Should I remove those lines and files?

Please wrap CLI stuff in triple backticks (```), so it gets rendered as code (the forum uses markdown). (I edited your post to add this.)

And, no. If you have Virtualmin installed in the recommended way (using our install script), you should not be using the Webmin.com repository. We provide Webmin packages in our repositories, and often have reason to wait to update due to bugs or incompatibilities found after it rolled out to the Webmin repos.

You can use whatever version you want, we can’t stop you. But, if we don’t roll an update into the Virtualmin repos there is a reason for it, as I said above, multiple times. I don’t know how else to say it.

Repeating myself: I recommend you just assume we’re trying to provide the best Virtualmin experience we can, and use the Virtualmin repos for Webmin (and Usermin).

Thanks @Joe .
I’ve done that now and will wait for 2.011

Webmin [2.011]
(Release 2.011 · webmin/webmin · GitHub)
But Not available in virtualmin.

Thanks @Joe

Please calm down! Virtualmin repos intentionally trail Webmin repos. I’ve explained this many times.

Thanks . @Joe

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.