Webmin>System>Bootup and Shutdown just spins

Nothing comes up for Webmin>System>Bootup and Shutdown. The server has been restarted a couple times, but the problem persists… but it used to work fine.

Where should I look to get a clue into what is going on?


Webmin version 1.600
Virtualmin version 3.94.gpl GPL


Did that screen work for you previously?

Also, do you see any errors in /var/webmin/miniserv.error?

And lastly, what distro/version are you using?


yes, “it used to work fine.”

CentOS 6.0.3

a simple “service httpd status” works fine BTW

didnt see any errors in there…

“it used to work fine” - yep I agree
and I also agree thats its still spinning.

at least on centos 6.3 x86_64
with wm 1.6 and vm 3.97 pro.
nothing weird in logs.
all other screens appear to work ok afaik.

Steps to reproduce: just click on the left menu link to ‘Bootup and Shutdown’
screenshot attached

I just upgraded wm to latest devel version 1.614.

but ‘Bootup and Shutdown’ is still spinning …

so I just checked on a Fedora 17 box and it does work OK on that

same here, still… it just spins. wm 1.6.1 and vm 3.97 pro on CentOS 6.3

thread started last Oct. I posted some weeks ago Its still an ongoing problem.

Its not the end of the world and there are ways round it - but can you fix it now please.

raised as an issue:


thank you


Our whole infrastructure is built on CentOS, both 5.9 and 6.3 currently. We’ve never seen this issue, so it seems odd others are. Was there anything done to your system recently, that may have caused the problem? In order to correct an issue, it needs to be reproduceable, and/or error logs need to indicate what the issue is, otherwise it’s like a needle in a haystack if it happens to some, but not every instance.

I suggest, if anyone is facing this issue currently, they add their comments to the “Issue” that “LonDoh” opened at:


Best Regards, Peter Knowles TPN Solutions

E: pknowles@tpnsolutions.com
P: 604-782-9342
W: http://www.tpnsolutions.com

nothing notable had/has been changed on the system
In fact when i first posted it was a (almost) new install (…I dont often use that screen but its often handy when setting up)
as I said I upgraded to latest dev version at that time, still on 1.614, same error

by ‘nothing weird in logs’ I meant these logs:

and webmin.debug - I turned on wm debugging then, and tried again now, but nothing obvious shows when accessing errant screen or otherwise.

issue appears with ff or opera
There are no console errors in browser

The fact it isnt happening in your case doesnt mean it isnt happening in mine/others.
If I dev team want specific info or access I’m happy to oblige - just need to ask.
But letting weeks go by without a response doesnt help it get pinpointed/fixed/me turned back to a happybunny :wink:

Best Regards



I see, well we use only stable version here so I can’t really comment on what may or may not be working in a “dev” version, hence because they there is a potential for bugs within these releases.

Just so you know though, Webmin 1.615 has been released today.

Best Regards, Peter Knowles TPN Solutions

E: pknowles@tpnsolutions.com
P: 604-782-9342
W: http://www.tpnsolutions.com

I see
whilst I am grateful for your input, I’m not exactly sure you do see

as I said before:
I just upgraded wm to latest devel version 1.614

So that was during setup and to see if it fixed the issue - which it didnt
I’m also not at all minded to go and throw another beta at a (now) live box, unless I’m sure there are definitely no probs and definitely some benefit.
no doubt there’s a changelog somewhere.

But it’s no big deal, it’d just be nice if it worked thats all.