Webmin restore failed


have just installed a brand new fresh server CentOS 6 the same one we are running now, even the hostname is the same, so when I tried to restore the Webmin backup from the file I received following error:

Starting restore of module configuration files from /tmp/.webmin/54851_2_restore.cgi …

Restore failed : Failed to open PID file

the Webmin backup file name: backup.tar.gz

Any idea ?

Thank You


I got the message as You can see “the restore failed” but it cannot be true as I saw all of the DNS domain names was imported, root password was changed etc…

Thank You


Hmm, so does it appear to be working for you, even though it showed that error?

Or did it fail to restore some things?


hm well I cannot be 100% sure that whole backup is sucessfull, as there is a lot of modified configurations in Webmin, impossible to check every detail :frowning:

My plan was to restore the Webmin first than Virtualmin (virtual servers) I assume that this is correct order ?

Bind DNS server was up with all of its domains, root password was changed as on the old server, and
some email features was also restored, but difficult to know if everything was restored.

so I am still afraid to migrate everything on the new server, because I cannot find out if the backup is sucessed or not …

Well, you’d have to be the judge of whether or not it worked… if you want to try again and see if we can get it to import cleanly – I might suggest doing a Webmin restart:

/etc/init.d/webmin restart

And then see if the restore works properly.

If it doesn’t, we’d need to get Jamie involved to look into what’s causing that error.


ok, I will test it again and let You know. I can try to go trough most of the modified settings and see if they are restored or not…

any way, I will let You know. Thank You for helping !!


I tried as You mentioned in previous post and it`s working just fine now.
Reversed a snapshot on ESXi server for this virtual machine running CentOS (Virtualmin) and I did a restore again and this time everything was fine:

Starting restore of module configuration files from /backup.tar.gz …

… complete. 510 files were restored.

Thank You for suggestion !


It appears there is NO SOLUTION to the common failed to open PID file error that occurs too often with virtualmin.
The only way we have found is complete restore, and lots of HOPE, because even restoring the entire system is not a guarantee.
It is one of those mystery errors that no one REALLY understands.