Webmin PostFix server: e-mail bounces with error "User unknown in virtual alias table "

Hi,

I have a VPS up&running with multiple virtualservers configured in VirtualMin.

Now I have added an e-mail user to one domain. In the grid with users I see this:

Name IMAP/POP3/FTP login … Login access
info info@ourdomain.com … Email only

I can login to roundcube for this domain, with the user info@ourdomain.com. I can also sent mails from this account. However, the account cannot receive mails.

I tried everything, and it all seems to be correct. Hostname is correct, user is listed correct, etc. But still receiving this error when sending mails to the account:

info@mydomain.com: host srvX.ourhost.com [188.166.7.215]
said: 550 5.1.1 info@mydomain.com: Recipient address rejected:
User unknown in virtual alias table (in reply to RCPT TO command)

Anyone ideas?

Argh, I found it now! :slight_smile:

Thanks to this post: https://www.virtualmin.com/node/8415

After all it was just a simple checkbox ‘is primary e-mail’

Glad you got it working, thanks for letting us know how you fixed it!

-Eric