Webmin not updating - killed

My VPS container doesn’t like to update webin. Tried from webmin, and tried Putty too (right after reboot).

# yum install -y webmin virtualmin 100% |=========================| 1.2 kB 00:00 virtualmin-universal 100% |=========================| 1.2 kB 00:00 base 100% |=========================| 1.1 kB 00:00 updates 100% |=========================| 1.9 kB 00:00 addons 100% |=========================| 1.9 kB 00:00 extras 100% |=========================| 1.9 kB 00:00 Setting up Install Process Parsing package install arguments Package webmin - 1.590-1.noarch is already installed. Package webmin - 1.585-1.noarch is already installed. Resolving Dependencies --> Running transaction check ---> Package webmin.noarch 0:1.600-1 set to be updated --> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size

Updating:
webmin noarch 1.600-1 virtualmin-universal 20 M

Transaction Summary

Install 0 Package(s)
Update 1 Package(s)
Remove 0 Package(s)

Total download size: 20 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Killed

Is that a memory issue?

Howdy,

If I had to take a guess, I’d guess that you’re using OpenVZ, and that you probably don’t have high enough resources allocated – and the Webmin update is pushing you up against them, which causes OpenVZ to kill the process.

You can verify that by looking in /proc/user_beancounters, and looking in the “failcnt” field. If any of those are non-zero, you’re receiving hard failures. If you receive hard failures for memory related limits, that suggests processes are being killed off.

If that’s the case, you could try to free up some RAM, or you could obtain more resources from your provider.

-Eric