Webmin not appearing

I’ve been using webmin to admin my server for a few years now. However, I haven’t had to add any new domains to the server for ages to haven’t opened up webmin recently. However, just tried to and the page just hangs and hangs, nothing appears. I’m running on default port 10000 remotely, so usually access it here:


There was an attack on my server a while ago as my hosting provider asked me to re config ssh access to ssh 2 only and on a different port to the default. I did this. I wonder if this has something to do with webmin not displaying? Have tried to revert ssh access to the default settings and restart the service and still no webmin.

Have also restarted webmin via commandline.

Still no joy.

Any suggestions gratefully received :slight_smile:

ssh and Webmin are in no way related.

I’d suggest making sure you have the latest version of Webmin (get it from webmin.com) first–if you haven’t used in in “ages”, then it’s out of date. :wink:

And, make sure there is no firewall between you and the server on port 10000 (possibly the firewall on the server itself).

Hi Joe

Thanks for the response. If I get the latest version of webmin will it then lose all my virtualmin domains and webmin preferences?

ie, is there a safe way to upgrade webmin via commandline?

Thanks again

Ah, you didn’t tell us you had Virtualmin, too. You leave us guessing.

But, yes, there is a safe way to upgrade, though you should make backups of your /etc directory before doing anything else (because I’m guessing from your tone that you don’t already have known good backups of your whole system…). So, backup /etc to a tarball somewhere:

tar czvf /root/etc-backup.tar.gz /etc

This will contain a copy of your /etc/webmin/virtual-server directory, which is where the Virtualmin meta-data lives. Please start keeping regular backups (once Webmin is working for you and it becomes easy)!

And then grab the appropriate package for your OS–whatever package type was used to install Webmin to start with (this is important…don’t grab the tarball if it was installed via RPM), and install the package. Webmin will keep all of the old configuration files, as long as it knows the prior version exists–this is why it’s important to use the same package type, otherwise it doesn’t know about the old version.

Anyway, you might check to be sure about the firewall thing…Webmin also provides an upgrade form in Webmin:Webmin Configuration:Upgrade Webmin, which of course will always use the right package type.

Hi Joe

Could you tell me how to check if a firewall is the problem?

Well, you could stop the firewall (iptables, on Linux systems) on the system itself–that’d be a good start on testing. I don’t think you’ve told us your OS and version, so I can’t tell you how to do that with any confidence. On many types of Linux system, something like “/etc/init.d/iptables stop” will do the trick (and “start” will bring it back after testing).

If that doesn’t do it, then there’s not much else we can tell you–if firewall is the trouble, it’d have to be your client system or local network (which only you can know anything about) or your hosting provider (which only you and your host would know anything about).

Hi Joe

I managed to get webmin working in the end by changing the default port and restarting webmin.

So I guess it must have been a firewall on the default port.

thanks for your help/suggestions.

Thanks for the update. Great to hear it’s working.