Webmin causing http access errors - Resolved

Seems that webmin is doing something every 5 minutes which is causing an error in the error_log.

[code:1]
access_log:
206.72.99.14 - - [20/Nov/2008:00:55:10 -0800] "HEAD / HTTP/1.0" 403 - "-" "Webmin"
error_log:
[Thu Nov 20 00:55:10 2008] [error] [client 206.72.99.14] Directory index forbidden by Options directive: /home/ezom/public_html/
[/code:1]

Anyway to have it NOT do that? Make the error log long and messy and prevents easily finding real errors.

tony<br><br>Post edited by: tbirnseth, at: 2008/11/20 07:39

Maybe you have setuped virtualmin to monitor your websites.
Anyway - when you point your browser at url which leads to /home/ezom/public_html/ what do you receive? I think that there is no index (like index.html or index.php - it depends on directive DirectoryIndex in .htaccess or httpd.conf) file so Apache is trying to index whole folder but hasn’t permissions for that.

Yeah, as rawww said, it sounds like the error you’re seeing is a symptom of another problem – Webmin’s just accessing the front page of the site.

That said, if you wish to disable that, the feature to disable is "Status Monitoring" – you can disable it system-wide in System Settings -> Features and Plugins, or per-domain in the Features and Settings when you click "Edit Domain".
-Eric

Thanks guys.

I simply did an 'echo “Nothing here!” > index.php" in that directory. Now that I understand it’s trying to do a directory listing because there’s no default page in that directory. I think that’s the simplest solution since I just haven’t populated that particular site yet.

thanks again