Webmin breaks php.ini?

I’m using Virtualmin GPL, all updates, on Centos. I’ve been writing a php program that uses session variables, it WAS working.

I used Webmin>others>file manager>edit to modify \etc\php.ini only to double the session time from 1440 to 2880.

Now sessions no longer work at all! I have put it back again to original, rebooted entire machine, still no sessions.

I’ve tried using the test code:

if(!isset($_session)) session_start();

echo $_session[‘test’];
$_session[‘test’] = “session is set and remembered, no matter the SID”;
echo ‘session was not set. <a href=“test.php”>Click here</a> to refresh’;
?> [/code:1]

It says no session no matter how many times I refresh… Could this be a permissions thing? Could Webmin have screwed it up? The owner is curently root and permissions 644…is this right?

You may want to look in the Apache error log to make sure no errors are being generated.

Also, I’d verify the permissions on the PHP sessions dir – what is session.save_path set to in the php.ini, and when you type “ls -ld /path/to/php/sessiondir”, what perms do you see?

I’m getting errors like:

[code:1] Use of undefined constant failed_logins - assumed ‘failed_logins’[/code:1]

but it has been set in:

[code:1]$_SESSION[‘failed_logins’] = 0;[/code:1]

So I don’t get why it says it’s undefined???

I can call phpinfo() and see that there is a session defined and the session ID so there is a valid session…

I can even see the session files…