Webmin BIND option missing - Allow-Transfers

I want to enable the allow_transfers directive globally on my server to restrict zone transfers to my server only, but I can no longer find the menu where I can put in these addresses…

I added the directive directly to the named.conf, but I can’t find any other way to manage it.

Seems like restricting zone transfers would be a good default install option for virtualmin/webmin.

I have fixed the zone default file, but that doesn’t change named.conf.

Am I overlooking it somewhere? Centos 5, Webm 1.36, VM 3.44

Thanks,

Will Sargent

Hi Will,
go to:
Webmin–>Servers–>BIND DNS Servers–> select the zone<domain>
This should bring you to the "Edit Master Zone"
select "Edit Zone Options"
Fill in the box "Allow transfers from…"

My Webmin-VM is GPL but they should be similar.
Good luck.
Joe

That’s true, if I want to edit the directive for every zone individually.

Bind 8/9 allows a global options directive as well, which is a lot easier than editing 20-30 zones individually, and that’s what I was looking for to edit via webmin.

The global directive is the default, unless specific zones have other information.

Also, from a configuration standpoint, it might be a good idea to disable recursive lookups as part of the virtualmin install, to keep those pesky ISP’s from blocking the DNS server.

I know that both those options are making some assumptions about what people are doing, but both options that I am suggesting are considered security best practices.

Thanks for the hard work Joe!

Will

Related documentation about the global directive at http://doxfer.webmin.com/Webmin/BIND_DNS_Server#Default_zone_settings