Webmin and Themes not showing tiles/images

I am not sure this is the right place to post. But this is the only webmin forums I have seen so far that comes close to public support.

The problem I am having is whenever I log into webmin, under ANY theme, none of the images show, it will simpily not download the tiles or buttons or anything like that. I have tried reinstalling, changing versions from newest to older ones. This is happening on 2 of my servers.

1 is a Fedora core 4 x86
other is a Fedora core 5 x64

I would tell you the webmin versions, but like I said, I have tried 3 different ones.

Also I tried both compiling from source AND rpm package installs. All the same, I have even gone so far as flush my iptables ( I know this wont be problem but I am desperate, since only reason I really use webmin for is iptables gui, and cant do anything with no buttons)

If you need any more info, let me know.
Thanks in advance,
Ryan Suess

Hey Ryan,

I am not sure this is the right place to post. But this is the only webmin forums I have seen so far that comes close to public support.

This’ll do. Quite a lot of Webmin users here (and both Jamie and I are around…though I tend to be the only one of us that consistently reads the forums, while Jamie tends the Webmin mailing list far more than I). If we’re not able to get you straightened out, the best source for general Webmin support is the Webmin mailing list:


I’ve never heard of this particular problem before, and I’ve never seen it myself.

But, here’s a couple of things to try:

Try a different browser. If it’s happening on two different servers with wholly different operating system revisions (which are known to work fine, and are used successfully by thousands of Webmin users, myself included), then it might be time to try changing another variable.

Check DNS resolution on the server. I’ve never seen DNS trouble exhibit it just this way before, but I know that about 90% of “it doesn’t work!” or “it is slow!” problems in any networked service situation is due to DNS problems.

Login to your server, and run the following:

host yahoo.com


If both of those do not return immediately with sane answers, then DNS is a problem, and you’ll need to fix it. To really be sure DNS isn’t a problem, you’ll need to confirm that your client machine IP can be reverse resolved successfully.

You might also, after checking DNS, check to be sure your box isn’t being eaten up by some runaway process. I supposed I can imagine Webmin spawning its child process to service your requests and then being killed by the OOM killer (or just the browser timing out waiting for some swap thrashing to occur as the kernel tries to free up memory for those child miniserv.pl processes). Use “top” and “ps auxc” to see what’s running, and whether you have enough free memory for something useful to happen (remember that “free”, “buffers”, and “cached” are all usable memory, and can be considered available for this discussion).

Hmmm…while we’re going down this track, check to be sure those two tools haven’t been compromised such that you can’t trust their results:

rpm -V procps

If this returns anything, then your system has likely been compromised. (This doesn’t prove when it hasn’t been, but it almost certainly proves when it has.)

Wow, talk about smacking me with the obvious. For as long as I can remember, I have used Mozilla. I just tried loading in I.E. (shudder) and it actually works fine. Now that I think about it this has been happening ever since mozilla updated a few weeks back. I cannot believe I looked past the most obvious thing, thank you so much.

Now I just gotta figure out what is wrong with the new mozilla that it wont load the images, I have already checked the standard options, privacy and content, but that seems to be in order. Now that I know what is causing it should be able to figure it out.

Again thank you for smacking me with the obvious stick, I really needed it.