Webmail.domain.tld should be redirected to usermin but is not (SOLVED)

By default the Server template is set to forward webmail.domain.tld to the Usermin interface which is great, but its not working for me. I keep getting server not found errors. I even tried to create it as a subserver but it still did not work.

How do I fix this?

Howdy,

My guess is that you aren’t using your own Virtualmin server as a nameserver, that you’re instead using a third party nameserver.

That’s fine, but that means you have to setup DNS entries for “webmail.domain.tld” on your nameserver.

-Eric

I am using the registrars DNS. I tried to set webmail.domain.tld as a cname entry to https://domain.tld:20000 but the problem is that cname does not allow certain characters so it would not allow the entry.

The CNAME entry you’d add would point webmail.domain.tld to domain.tld. When you access webmail.domain.tld, it’s the server’s job to handle the redirect to port 20000.

-Eric

Ok, I did that but its not working. I’m getting Page Not found.

The redirect is setup, and the port is open but no luck…I must be missing something

I’m not exactly sure how I got it working but it does. I think it had something to do with another redirect setting for the tld that was somehow over riding the webmail redirect.

That’s great, I’m glad you got it working!

-Eric

I have setted A record and CNAME for my domain, but it is still not redirecting

admin.globalnomad.co

I have no idea what is wrong and how to change it ><

Hi ckara,

This thread has been closed for 3 years. You should be starting a new thread of your own, or directing your specific virtuamin support questions to virtuamin support. Comtoistech is in no way affiliated with virtuamin support.
In any case your question sounds very general and not virtuamin specific, any changes to your DNS settings can take up to 48 hours to become active, and that is with any domain provider service. You may just have to be patient. Good luck.