"webmail.domain" DNS record not being created

Hi all,

I am running Virtualmin Pro on CentOS 6.3 x64 and have a successful installation set up that is serving several Web hosting customers.

Lately though some customers have been complaining that their “webmail.domain.tld” addresses are not working, and upon a bit of investigation today I found that this is because these DNS entries do not exist. This means that apparently an entry for “webmail.domain.tld” is not being created when a new virtual host is set up.

I haven’t found any settings in the GUI, specifically under “Server Templates”, that would control the automatic creation of this DNS entry.

How can I resolve this apparent problem and enable the creation of “webmail.domain.tld”?

Thanks for any assistance provided.


Check the page:

Virtualmin > System Settings > Server Templates > Default Settings > Apache website

Scroll halfway down the page, and make sure: Redirect webmail.domain to Usermin? is set to Yes and URL for webmail redirect is set to Use domain name.

When this is setup as defined above, it will automatically add the Apache configuration changes, and DNS records upon creation of a domain. If this was turned off by accident or intentionally then it won’t work.

*** Assuming these settings were not changed (as they’re turned on by default), then you may have experienced a bug at some point. If so, I’d recommend because you’re Pro user opening an Issue on the topic for further assistance. ***

Best Regards, Peter Knowles TPN Solutions

E: pknowles@tpnsolutions.com
P: 604-782-9342
W: http://www.tpnsolutions.com


Right now, in the “Apache Website” pane of the server template editor, I have Webmail redirection to Usermin set to “no” and a custom Webmail URL entered. This is the same setting I’ve had for a while now though yet Virtualmin still refuses to create the DNS records and I’m not sure why. I installed Roundcube on a specific virtual server which is why I want Virtualmin to point to that rather than using Usermin.

Any ideas as to why this could be happening?



You would want to set “Redirect webmail.domain to Usermin?” to “Yes” in order for that to work properly.

The term “Usermin” there is misleading, as it’ll redirect where ever the redirect URL points to.