webalizer shows own site as referrer

Hi, I’ve been looking, but can’t find a solution yet to this: At all webalizer reports on my server, the ‘own’ domain fills 99% of the Total Referrer table in webalizer. (Which is something I don’t want.)

So I went to webmin - servers - webalizer logfile analysis - edit global options

“Referrers to hide from tables” is empty there, “Referrers to totally ignore” has ‘localhost’ in it.

If I click on a log file of a virtual server in webmin - servers - webalizer logfile analysis, and then ‘edit options’, at ‘referrers to hide from tables’, it’s filled out perfectly:

*.gran-canaria-info.com where the server is gran-canaria-info.com. ‘Referrers to totally ignore’ has ‘localhost’ in it again.

My question then, why, when I look at the webalizer stats, is the Total Referrer table filled with gran-canaria-info.com urls?

What am I missing?



Well, just to be sure that you’re tinkering with the options that would be relevant to your domain – what you’d want to do is log into Virtualmin, choose your domain from the drop-down, then click Logs and Reports -> Webalizer Report -> Edit Options, and check the Referrer options there.


Hi, I’ve never really got this working :slight_smile:

At “Referrers to hide from tables” this is filled in: *.gran-canaria-info.com

standard stuff with virtualmin I believe.

However, at the webstats, the whole table is full with http://www.gran-canaria-info.com

1 298954 17.53% - (Direct Request)
2 223688 13.12% http://www.gran-canaria-info.com/
3 41958 2.46% http://www.gran-canaria-info.com/gc-directory
4 19153 1.12% http://yandex.ru/yandsearch
5 16142 0.95% http://www.gran-canaria-info.com/index.php
6 6125 0.36% http://www.gran-canaria-info.com/photos
7 4346 0.25% http://www.gran-canaria-info.com/photos/events/la-rama-agaete-august-2008/beaches/puerto-rico/puerto-rico-beach-488

etc etc

What can I do to get rid of all the gran-canaria-info.com referrers?

(and doesn’t everybody have this like this with virtualmin?)

Thanks yet again!


The config files used by Webalizer are located in “/etc/webmin/webalizer”.

You could always open up the config in question, and manually verify that it appears to be setup properly.


Ok, I presume more people would want this. To get it to work, you have to do this:

(would be cool if there was a way in which we’d only have to this once though, and not for every domain/server, but I don’t know how to do that :slight_smile: )

virtualmin -> pick a domain / server -> Logs and Reports -> Webalizer Report -> Edit Options

at “Referrers to hide from tables” your domain will be shown like this:


just remove the *. so it only shows domain.tld

That’s it, from now on, in the “top referrers” you won’t see your own site anymore.

(p.s. I know this sounds weird, as the *. shouldn’t influence this, but you can test it, it does.)