Way to prevent Virtualmin from messing gre tunnel configuration in Centos7

I recently encountered bug (https://www.virtualmin.com/node/67602) and look for a runaround for it. Currently my best idea is to disable the network configuration module in Virtualmin configuration panel. However as other network-related changes need to be made occasionally by people that use Virtualmin the module has to be enabled temporary, then disabled again and a script that restores GRE tunnel config from backup and fixes the messed interface has to be run manually by people, who find this to be something pretty hard.

Is there a way to configure Virtualmin to ignore specific configuration files.