Warning - errors were found in this domain's DNS records : This domain has email enabled, but none of the MX records...

I recently started using virtualmin, so I’m fairly new, although I’ve some experience with Webmin/BIND.

CentOS 6.2/Virtualmin 3.92.gpl

I’ve succesfully setup 2 different domains, BIND with auto tranfer to secondary via Webmin. Websites working, now I came to the point of also setting up e-mail.

So I check ‘Mail for domain enabled’.

When I go to: Server Configuration -> DNS Records

the following message at top of the page appears in red:

Warning - errors were found in this domain’s DNS records : This domain has email enabled, but none of the MX records mail.mydomain.com point to it. Either the MX records should be corrected, or the email feature disabled if mail is hosted externally.

The mail does actually work! (I tested it by sending mail from my gmail account.)

It created 2 extra records, which seems fine to me:

mail.mydomain.com. IN A
mydomain.com. IN MX 5 mail.mydomain.com.

Why do I get this message, only thing I can think of (I’m a newbie to Postfix), that I send up my machine behind NAT (it’s a static on a Cisco ASA from a real world IP to my inside IP)
(I set System Settings -> Virtualmin configuration -> Networking settings -> Default IP address for DNS records to it’s public IP

So outside public IP: and internal IP:

Any ideas?

sounds okay actually. Did you also check your domain on www.intodns.com to see if it comes up with any errors?

Hi Ronald, thanks for your comment. I indeed did do a DNS check with intodns.com and dnscheck.iis.se (all green).

Both reporting evertyhing is fine. I did some more testing and technically everything is working just fine.

Actually I want my MX records to point to 2 edge servers (Symantec Messaging Gateway). So I changed the MX records to these IP addresses and I keep getting the same message (Everything is working fine again, but this time I can understand the message, because it’s pointing to addresses not known by virtualmin. The edge servers actually deliver the mail internally)

I still got the idea I’m missing some sort of setting somewhere (besides the fact that it is annoying, telling things are wrong, while actually evertyhing is working, especially when other users log in).

Hmm… Actually I think there’s something wrong with my basic network configuration.

The DNS servers I’ve added via Webmin (Network Configuration) are not persisted when I reboot the machine. Got to figure out first why this happens…

If your DNS servers are changed each time you reboot, that may just be due to you using DHCP. There’s some info on that here:


As far as the warning you see in the DNS Records page – we wanted to let people know when the various DNS records there weren’t pointing to the local server, but I don’t think that message you’re seeing is the right way to do it.

There’s two problems there – one, I don’t think it’s taking into account the idea that you’re using NAT.

And two, it shouldn’t say that there’s an error, as the setup could be intentional. If the records really aren’t pointing to your server. it should simply say that it was detected that, and not imply an error.

I’ll talk to Jamie about tweaking some of that :slight_smile:



Hi Eric, first of all thank you for taking the time to read my question.

I’m sure I’ve setup a static IP ( and excluded this in our DHCP server… The (AD) DNS servers in my DHCP server actually differ from what the CentOS is starting up with (it’s setting the DNS servers to what I actually configured during installation). But to lack of knowledge :wink: I can’t find this yet. I expected this to be in /etc/resolv.conf , which is actually looking good now… Anyway, I’m sure I can figure this out by googlin’ a bit more…

EDIT: I’m not sure of anything anymore right now ;-). So I just rebooted the server and resolv.conf is overwritten… below the contents:

Generated by NetworkManager nameserver search

(So this NetworkManager, who’s that? Is overwriting my resolv.conf…)

And you’re right, when I intentionally set the MX records up to make use of my edge servers, it’s complaining too (it won’t always let me add these records, depending on how I try to add the MX records :wink:

Thanks again for this fantastic product which can even used by me (with very little knowledge of Apache/Postfix)!

Ok, figured this one out, my /etc/sysconfig/network-scripts/ifcfg-eth0 contained:

DEVICE="eth0" NM_CONTROLLED="yes" ONBOOT=yes HWADDR=00:50:56:BF:00:0E TYPE=Ethernet BOOTPROTO=none IPADDR= PREFIX=16 GATEWAY= DNS1= DOMAIN= DEFROUTE=yes IPV4_FAILURE_FATAL=yes IPV6INIT=no NAME="System eth0" UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03

I can either change the settings or set NM_CONTROLLED=“no” and PEERDNS=“no” (and remove /etc/resolv.conf.save :wink:

Probably uninstall NetworkManager will do the job too, but since it’s working just fine now I’ll leave it as it is…

the networkmanager can be fired. it messed up my chi for sure

this is 1 of the things what redhat has changed since the 6.x series and received many complaints.
The behaviour of networkmanager -IMO- is actually only interesting if you run the desktop on centos.

On one of my boxes i have removed it and went back to the old 5.x network behaviour.

Hoi Ronald :wink:
Right, I googled it and found many peopl struggling with the NM, I’m gonna fire him! (or her)