VM says: Quotas editing has been disabled


I get the following message during Virtualmin’s ‘Checking Configuration’:

The module could not find the mount point for your home directories filesystem /home. Quotas editing has been disabled.

Therefore, VM will refuse to display any quotas on the System Info page and quotas set for the virtual host account are not enforced. All users show ‘unlimited’ in Webmin, even though I set a 1GB limit for the user in VM.

But, quotas seem to work outside of Virtualmin:

quotaon -ap
group quota on / (/dev/vzfs) is on
user quota on / (/dev/vzfs) is on

quotaon -av
quotaon: using //aquota.group on /dev/vzfs [/]: Device or resource busy
quotaon: using //aquota.user on /dev/vzfs [/]: Device or resource busy

Setting quotas works from within the Webmin Quota page, and they are enforced, which I’ve tested.

I am using Virtualmin on a clean Debian 5, which is installed inside a Virtuozzo container at the webhost. Apparently quotas cannot be turned off, due to the OS running inside a VPS. (Kernel is Linux 2.6.18-028stab060.8 #1 SMP)

Since quotas are enabled on the OS, I can use the quota functions from the command line or in Webmin, but VM refuses to use them, because its configuration check does not recognize that quotas are working.

Is there a setting in VM (or in its config files) which will tell it to ignore its (erroneous) quota self-test and to enable the quotas anyways by way of a manual override?


What are the contents of these two files:

  1. /etc/fstab

  2. /etc/mtab


[code:1]h1601022:~# cat /etc/fstab
proc /proc proc defaults 0 0
none /dev/pts devpts rw 0 0
h1601022:~# cat /etc/mtab
/dev/vzfs / reiserfs rw,usrquota,grpquota 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,nosuid,noexec 0 0[/code:1]

So, fstab has no indication of quotas (or even a filesystem). I’m guessing this is confusing Webmin/Virtualmin. Maybe you should copy mtab over fstab, and try again (there might still be confusion on reboot, as the files might be recopied from outside the virtual server). I dunno. I’m not deeply familiar with the way Virtuozzo/OpenVZ does things.

Thanks Joe, that worked - after copying mtab into fstab, rechecking the config and rebooting the server. fstab was still preserved after reboot.


Hrm, according to this here bug report:


It sounds like that should have worked, that Virtualmin should have understood that Virtuozzo enables quotas in /etc/mtab.

I’ll mention that to Jamie.


Looks like this is a slightly different issue … but I will fix this in the next Virtualmin release, by having it look at /etc/mtab and /etc/fstab.