Virtualmin webprefix issue

I have recently decided to stop using Webmin via a Apache proxy for security reasons (as its treated as localhost). Now I have reverted the changes in “/etc/webmin/config” by removing them from the file.

Today i noticed that some of the links on webmin where still being prefixed with the /webmin/, if you look at the screenshot you will see that the stuff i have circled are all prefixed with /webmin/. It is only those URL’s which have this issue every other URL in webmin works fine.

For example.


should be


How do i fix this?

Because of this prefixing which shouldn’t be happening anymore those links are inaccessible with a “Error - File not found” unless i manually remove the prefix.


Just like to state I have tripple checked and the prefix thing is remove and redirect thing is gone. I have tried restarting the server twice and webmin process hundreds of times.

Have you done a forced reload (ie. shift-reload or ctrl-reload) in your browser? That may be needed to clear client-side caches of the old HTML.

I managed to fix this by going to

System Settings -> Re-Check Configuration

and it reset the links for me. If you are unable to get to the page like me this is the URL.

Not to sure exactly what it did but it fixed the issue. I tried on a range of PC’s and all is working now :).