Virtualmin/Webmin/Usermin can only use one certificate?

Today I cheerfully clicked “Copy to Webmin” in the Manage SSL Certificate page so that I don’t get a cert warning when I log in using that domain name. I was logged into Virtualmin via it’s IP address at that moment. Upon completion, the page displayed a bad-cert error message. It identified the cert as belonging to the domain I had been managing. FireFox didn’t even give me the usual “proceed anyway” link.

I seemed to have locked myself out of my Virtualmin administration gui!

In a new browser tab, I opened the domain I had been working on, appended :10000 to the url, and found the Webmin login. I was able to log in as Master admin again, and roam around the settings. A little experimentation showed that If I “Copy to Webmin” any other domain’s cert, then, it too, became the ONLY cert that worked. And also with Usermin, which would have it’s own separate cert!

This is NOT what I was expecting, and there should be some clear warning before we click these buttons!

I thought I was adding the cert for that domain to a POOL of certs which Virtualmin could use natively. It seemed reasonable that each separate domain owner should be able to add :10000 to the end of his own domain and manage his server. Using his own cert. It certainly seems more confusing to ask the admins of each of the other domains to now use a separate domain to admin it and access user emails options.

So how do I reverse this process and reinstall the self-signed cert that many other people have already accepted in their browsers? I can’t find a “revert” button. I seem to be stuck with the Let’sEncrypt cert meant for one particular domain. Even if I can just install a new self-signed cert, I have 3 PCs I’ll have to go through rigamarole to update, since I run them in private browsing mode and can’t permanently save a new cert in that mode.

Better yet, how to I enable each individual domain to be able to use it’s own cert with Webmin and Usermin as desired?