virtualmin/webmin login no ssl

Hi all,

When I login on this page I get this message

Error Bad Request
This web server is running in SSL mode. Try the URl instead.

What is this ?

I don’t find any connection in bind server between ns2 and fx3432 :frowning:
I can say is our system hostname.

I’d like to change it to

Thank you very much<br><br>Post edited by: Maurizio1230, at: 2008/06/08 04:47

I looked up your PTR record:
host domain name pointer

Ask to change the PTR record to

PTR as in the reverse for the IP.

How ever you can use because its still the same IP.

$ host has address mail is handled by 5

How can I change this PTR record?

How can I change this PTR record?

You probably can’t. Reverse resolution is usually handled by your hosting provider or ISP, and that’s usually fine. As long as the names resolve back and forth correctly, it doesn’t matter at all what name an IP resolves to. But, if the name resolves back to something else, it’s a problem and will prevent mail delivery (and cause other problems). If that’s the case, you’ll need to get your provider to correct the record.

BTW-If you just want Webmin to direct you to a different name, that can be done in the Webmin configuration. Look in Webmin:Webmin:Webmin Configuration:Ports and Addresses and set the option labeled "Web server hostname" to whatever name you want.

Do you advice me to have the PTR record changed to

Thanks Joe

Do you advice me to have the PTR record changed to

Probably. It’s their network…they ought to know what sane values are. It’s currently wrong, though, for sure, since it points to a name that does not resolve (, as Scott explained). That’s broken, so they need to fix it to something that does resolve, and it appears does resolve correctly. So, yes. Ask your host to fix the PTR for that IP.

Forward dns MUST match the reverse. I have seen to many mail servers setup wrong and mail bounced just for this reason.

If the hostname for your mail server is – then the reverse for the IP MUST be

$ host has address

$ host domain name pointer

Forward dns MUST match the reverse. I have seen to many mail servers setup wrong and mail bounced just for this reason.

Not quite right.

There can be thousands of forward DNS records that point to a single IP. There will only ever be one reverse. The forwards cannot all match the reverse.

The reverse record must resolve to a forward address that resolves back to the IP. That’s the only requirement for a PTR records.

For example, has this PTR:

[joe@delilah ~]$ host domain name pointer

And that name resolves back to:

[joe@delilah ~]$ host has address

That’s all that matters. The PTR does not have to be “” or “” or any of the dozens of other names system system has. It can be something wholly unrelated to my system–in this case a standard name in the pool of names theplanet uses for reverse resolution.

Reverse resolution is dead simple and it doesn’t matter what names are being used–but it has to work, in both directions, or mail will bounce.

I meant if the mail server is using then the reverse must match that because more and more mailservers are rejecting mis-matched forward-reverse.

Hmmm…Are they? I haven’t noticed an increase in bounces from our system. But it could be a “spammy” characteristic for some servers, I guess. But it’s still extremely common for reverse resolution to not be delegated to the customer at colo and dedicated server hosting facilities that it seems like one would bounce an awful lot of mail if you used a rule like that.

AOL and Yahoo are known to reject mis-matched forward-reverse and M$ hotmail/msn always reject it.

sorry but what do you advice me to choose? I have two ip on this server. shared by all others site.

Thank you very much

What do you mean? What’s to choose? They both ought to resolve correctly, and it appears neither does. But Postfix will send generally outgoing mail via the “default” interface–usually eth0–though the routing table on the system can alter that.

And both of your mentioned PTR records fail to resolve. You need a PTR record on whatever IP is your default route, and it needs to resolve to the correct IP. (Again, the name used in the reverse record is irrelevant, as far as I know…though Scott has asserted otherwise, and I don’t know enough to argue strongly one way or the other…but I’ve never cared about what name, and I’ve never had problems with mail bouncing, including to Hotmail, AOL, and Yahoo–we have customers with all of those addresses here at, and our reverse resolves to and the mail server claims to be or or something along those lines).

So who is “”? Is that your hosting provider, or is that you? I’m now unsure whether we’re looking at provider generated reverse records, or delegated records that you haven’t configured correctly.

Now I understand. I create two A records pointed to my two domains.
May you check if the A records resolve to the correct IP.

Thanks Joe.

Edit:*…pointed to my two ip.

I’m gettting the ssl error message and have installed the manual way and by using the script. No matter what I do still can’t actually fully login to Virtualmin. Username and password is accepted and all I’m seeing is a blue circular motion on the screen and NEVER actually logs in. Was getting an error message such as missing “Perl module Authen” and I installed that. As for a ptr record don’t understand why I can’t login to Virtualmin by ip as I can do that with Webmin. Using Centos 6.8 & 7 and still get the same result as listed above. Any help would be appreciated! ****Mods delete this post as it’s getting no replies.