Virtualmin & Webmin locked out of administration area's

Hi Everyone,

I desperately need help. I did something and really messed up my administrative abilities.

I am logged in to virtualmin as root, but if I try to access things like “Edit Users”, I always get the same error.

DBI connect failed : Access denied for user ‘comtoistech’@‘localhost’ to database ‘mysql’

I tried the suggestions on other topics for resetting passwords via the terminal but nothing has fixed the issue.

What I don’t understand is that I can log into phpmyadmin as the user “comtoistech” without a problem, and my website seems to be working ok, mostly.

If I am logged in as root, why is it telling me it can not access mysql as comtoistech@localhost.

I think this may have started when I was changing some user names to reflect the new domain, and I may have removed one under the old name, but can’t be certain.

I read somewhere that you can just add the user under localhost but I can’t find anywhere to do that, and if I try to access anything under Webmin for Mysql, like user permissions, database permissions, or host permissions, I get the same error.

Can anyone help me? Pleeease!


Under Webmin / System / Users and groups

I noticed that the user “comtoistech” is only part of the group “comtoistech”, and the group “comtoistech” is part of the group “apache”

Should it also be part of the group “mysql”?

***Update: Well that didn’t work either.

After logging into Virtualmin as “comtoistech” instead of root, I noticed an option under server configuration for change password, which was not there under root login. So I tried to change it to the same password I was already using and got this…

… Administration user failed! : DBI connect failed : Access denied for user ‘comtoistech’@‘localhost’ to database ‘mysql’ at /usr/libexec/webmin/ line 1361.
Updating Webmin user …
… done

Saving server details …
… done

Re-loading Webmin …
… done

Still lost.

In the database “Information Schema” under “User Privledges” it shows

GRANTEE = ‘comtoistech’@‘localhost’

Is this correct? Should IS_Grantable be “Yes”?