Virtualmin virtual-server version 4.09 released

Howdy all,

Virtualmin virtual-server version 4.09 is out for all operating systems.

Changes since 4.08:

  • Even more script installer updates.
  • Added a warning message on the password change forms if a domain’s MySQL or PostgreSQL logins would also be effected.
  • Added Virtualmin configuration options for commands to run before and after a reseller is created, modified or deleted (pro only).
  • Custom fields can now have tooltips.
  • A bunch of small bugfixes and feature improvements

After the update, the packages hosted here for 64-bit appear broken. I get error messages specifically for procmail-wrapper and scponly

http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-trusty/

Thanks for the heads up… what messages are you seeing exactly?

Attached is the screenshot of the install and the directory in question. contents-amd64* looks pretty small in comparison to the same files for precise, etc.

This should be working now – let us know if you see any additional issues.

-Eric

This doesn’t seem to be in the GPL repository yet.

Howdy,

I verified that Virtualmin 4.09 was in the CentOS, Ubuntu, and Debian 32 bit and 64 bit repositories… it seems to be there for all of those.

Which distro, version, and architecture are you having problems with?

-Eric

CentOS 6 x86_64, I am not seeing the update on any of the servers I manage, I cleared yum out and it still won’t update.

Do you have the virtualmin-universal repository enabled?

Yep, reinstalled virtualmin-release just to make sure even.

Weird. It’s definitely in there. I’ve verified the signature, the repodata, Epoch/version, etc. And, my machines have picked it up.

Can you try running:

yum clean all
yum update

And see if it sees the new package after cleaning up metadata? Maybe your yum grabbed it while it was in a weird state or something. I think createrepo handles files in a safe way, but I dunno, maybe there’s a race condition that can lead to a cofused yum metadata situation.

I had done that several times, but I just did it again and now the update is showing! Thanks Joe!

Argh, that should be:

yum clean all

yum update