Virtualmin virtual-server module version 5.0 released

Howdy all,

I’ve just rolled out version 5.0 of the Virtualmin virtual-server module. This is a major new release (thus the 5.0 designator). This release will coincide with changes in the install script happening tonight, to make Authentic Theme the default theme and Filemin the default file manager.

There will be some additional announcements about changes in the Virtualmin system as a whole (including instructions for updating your installations to the new defaults, should you want to do so), but, this announcement just covers the virtual-server module itself (which also has major new features and updates).

Changes since 4.18:

  • Updated the Piwik script installer to version 2.14.3, Wordpress to 4.3, phpMyFAQ to 2.8.24, FengOffice to 3.3, Dolibarr to 3.7.2 and 3.6.4, MediaWiki to 1.25.2, Coppermine to 1.5.38, Magento to, Dokuwiki to 2015-08-10a, SugarCRM to 6.5.22, ownCloud to 8.1.1, Drupal to 7.39 and 6.37, Django to 1.4.22, Trac to 1.0.8 and 0.12.7, FosWiki to 2.0.1, CMS Made Simple to 1.12.1, Typo3 to 6.2.15, Ghost to 0.7.0, Joomla to 3.4.4, and phpMyAdmin to
  • MX records for a domain can be pointed to a cloud mail filtering provider on the Email Options page, or using the modify-mail API command.
  • Added the rename-domain API command, to allow changing the domain name, username or home directory of a virtual server from the command line.
  • Removed support for Apache versions older than 2.0.
  • Backup logs are now associated with the scheduled backup that created them, and are linked in the UI.
  • The Excluded Directories page can now also be used to enter MySQL and PostgreSQL databases and tables to exclude from backups.
  • The paths to additional PHP versions can now be entered on the Virtualmin Configuration page, under PHP Options. This also makes it possible to run PHP version 7.
  • Added a tab to the Manage SSL Certificate page to request a certificate from the free Let’s Encrypt service.

The big changes are PHP 7 and much more flexible support for many PHP versions, as well as better detection of SCL-installed PHP versions, and support for Let’s Encrypt! Let’s Encrypt provides free domain-validated SSL/TLS certificates in an automated fashion, making it easier and cheaper to secure all of your websites (without the certificate warnings that come from self-signed certificates). Webmin has gotten support for Let’s Encrypt, as well, in its latest release.

Because this release has really big updates, there will likely be issues (whether in usability or simply bugs); please let us know if you have problems with the new features!



This is really great news. One question though - will the virtualmin implementation of Let’s Encrypt also autoupdate the certificate every 90 days?

Actually I read that every 30 days is recommended.

I like the new looks alot.

Trying to get it to detect php7, i tried /usr/local, /usr/local/php7 and /usr/local/php7/bin/ in “Additional locations for PHP commands”

Then re runs check configuration and still doesn’t seem to detect the php7 with any of the paths.

What am i doing wrong ?

@skelgaard, probably best as an issue in another part of the forum, rather than here.

How have you added PHP 7? By a repo? Where is it installed?

If you open a do Virtualmin > Server Configuration > Website Options Then scroll down and click PHP Information what does PHP versions installed say?

@lostandfound could be yes, but other may have same problem with this new one…

i have created a new threat here with the answers to your questions

I don’t know if is a bug or what, but when you get a cert for a domain with aliases, it only generates for the main domain and not the aliases. … shouldn’t all aliases be added with -d command ?

Yeah and the www alias as well, I opened an issue for this:

I installed PHP 5.5,5.6 and 7.0 versions. All of them are detected and working. I installed PHP 7 from remi"s repository.

Thank you for this great “major” update! I love it :smiley:

Awesome !

For letsencrypt, it would be nice to also add the domain name with www, I had to create by myself here, otherwise very good work!

Really loving the new html5 theme. Thumbs up to everyone that worked on it!

Bravo on the new look!

Something weird with php configuration, I tried a new install of centos 7.1, all went well, with scl I install php 5.6 so I had php 5.4 and 5.6, and the same in service (PHP 5 configuration and PHP 5.6 copfiguration). I wanted to try php 7, so i uninstalled php 5.4 and intalled php 7, it was ok in php versions, but it still showed me the configuration for 5 and 5.6

Then I decided to uninstall php 7 and put back 5.4, + 5.5, then I had in the list configuration for php 7 and 5.6 (after refresh). I then refreshed another time, and now I have config for 5, 5.5, 5.6, 7 ^^

I am trying to install a SSL certificate from letsencrypt. Virtualmin complains that the letsencrypt binary is not installed. So I downloaded letsencrypt, but now I am unsure where I should place the binaries? Where is virtualmin searching for them?

  • Peer

@peer.dicken go to webmin -> webmin configuration -> press gears icon -> fill out “Full path to Let’s Encrypt client command”

O.M.G. that was too obvious :slight_smile: Thanks a lot!

I’m currently adding packages to our repositories, so it’s a little more obvious how to do it (and it will be automatic with new installs on modern operating systems, in a couple days). I didn’t want to wait any longer to get 5.0 out, but it’s kinda happening in stages, with many of the features being a little unobvious until all the pieces are in place. New virtualmin-base packages are going out, and letsencrypt.

Unfortunately, the official Let’s Encrypt client is really demanding in terms of dependencies. It has a long dep list, and it requires very, very, new versions of some of them (even CentOS 7 requires a dozen or so upgraded packages). Which rules out easily running Let’s Encrypt on older operating systems. There are lightweight alternative clients, which have fewer capabilities, but require a lot fewer dependencies. They didn’t exist when Jamie was writing support into Virtualmin, so they aren’t supported yet, but one of them will be in a future release. Hopefully soon-ish.

In short: Let’s Encrypt support currently needs the official Let’s Encrypt client; it’ll be in our repos today or tomorrow for recent operating systems. Older systems will need a bit more time (or more ambition on the part of admins to get the client installed and running!). We’ll keep tweaking Let’s Encrypt over the next few weeks until it is easy/automatic for everyone.

Also, for Let’s Encrypt support on CentOS 7, there is a COPR repo available which makes it pretty easy to get going:

In short:

# cd /etc/yum.repos.d
# wget
# yum install letsencrypt

It also requires the EPEL repo to be installed and enabled, so add that one before doing this step.

I just use the repo from here and it works fine with that without tons of wierd packages :wink:

About the bug I talked about above, my final installation looks like this now:

php 5.4 as the system installation, and 5.5, 5.6 and 7 with scl packages, but in the service it looks like this:

(it kept PHP 7 from when I replaced php 5.4 with php 7 as the system php, when I put back 5.4 it didn’t remove the line, I think)