Virtualmin virtual-server module version 4.16 released

Howdy all,

I’ve rolled out Virtualmin virtual-server version 4.16 for all repositories (actually 4.16-2 in the Professional universal yum repo, due to a typo, but it’s the same as the 4.16 in all other repos).

Changes since 4.15-2:

  • Updated the phpMyAdmin script installer to version 4.3.12 and in the GPL version, and many others in the Pro version.
  • Fixed a few backup-related bugs triggered when a user is out of quota.
  • Added the ability to force re-setup of a cloud backup provider login.
  • If the aws command is installed, Virtualmin will call it to perform S3 operations rather than using it’s own code. Because this command is developed by Amazon, it can be expected to be reliable in the face of S3 API changes.
  • Copying a domain certificate to servers like Dovecot now takes changes in the CA cert into account.
  • Fixed creation and display of IDN-encoded domains when using a UTF-8 language.
  • Fixed a bug that prevented restores from uploaded files for non-root users.
  • Fixed bugs setting up OpenDKIM on CentOS 7 systems.

As always, let us know about any problems you run into.


All was working well till i received update 4.16 yesterday and once installed Apache2 would not start. NGINX mySQL BIND9 SSH ProFTP all work with update. On Apache start

Failed to start apache :

Starting web server apache2 [Wed Apr 01 11:13:01 2015] [warn] NameVirtualHost fe80::21b:24ff:fe51:2b93:80 has no VirtualHosts [Wed Apr 01 11:13:01 2015] [warn] NameVirtualHost has no VirtualHosts (22)Invalid argument: make_sock: could not bind to address [fe80::21b:24ff:fe51:2b93]:80 no listening sockets available, shutting down Unable to open logs!

Deactivated all virtual websites and tried again, same story.

On validation i get; Apache website : No Apache virtual host for found on all three virtual sites.

I checked there are no running Apache instances to “kill” but there are 2 running processes that say they are not running (so cannot kill) but refresh themselves

18665 root 0.0 % sh -c ps --cols 2048 -eo user:80,ruser:80,group:80,rgroup:80,pid,ppid,pgid,pcpu, … 18666 root 0.0 % ps --cols 2048 -eo user:80,ruser:80,group:80,rgroup:80,pid,ppid,pgid,pcpu,vsz,ni …

I am assuming this is a SSL crt issue. I have tried unencypting and issuing a new encrypted cert still no luck.

Any advice or help would be much appreciated


This appears to be a duplicate of another issue, I’ll respond to your thread here:

Hello there!

After upgrading to the 4.16 version the following error started to appear in scheduled backups:

Creating backup for virtual server ….com…

Copying virtual server configuration ..
.. done

Copying records in DNS domain ..
.. done

Saving mail aliases ..
.. done

Saving mail and FTP users ..
.. done

Backing up mail and FTP user Cron jobs ..
.. none to backup

Copying Apache virtual host configuration ..
.. done

Copying Apache log files ..
No such file or directory


This is a forward to another server and it occurs for that server only.
If I disable the “Include log files” option in backup “Features and settings” the backup is completed successfully.

The other servers are backed up successfully and the problem appears for the forward only.

edit: My server is based on CentOs 6.6


There’s a bug report and temporary workaround for that issue here:

Hi, I see the new feature “Using the aws command for S3 operations” and I am on AWS EC2 with backups to S3, so I follow the instructions to install pip and aws-cli, but still I see “Error - File not found” when I click the Try it… link from VM System Info. Restarted Webmin, same result. However, if I do a single scheduled backup, it works, success, no problem.

Maybe I am wrong in thinking this will be more efficient option in the long run than using the standard VirtualMin Backups, which has thus far been the only reason I continue to pay for VirtualMin Pro?!?!

Is this a problem with the Try it… link?
…seems it should be:
hey, that’s the same!

Seems it does not work in the iframe or direct URL.

But if I click Backup and Restore > Restore Backup, I see the correct screen: Restore Virtual Servers

!!!HOWEVER!!! When I attempt to restore, using the correct bucket/file path… I get “Restore failed : The specified source is not a Virtualmin backup : Failed to list S3 bucket :”



Yes, it’s possible you are seeing a bug there… you may want to file a bug report using the Support request above, and then we can work with you to resolve what’s going on there.



I upgraded phpmyadmin 4.3.6 to 4.4.1 and started getting errors whenever I browsed a database. I see a popup with “Some errors have been detected on the server! Please look at the bottom of this window.” and an extensive backtrace starting with “Notice in ./libraries/DisplayResults.class.php#2747 Undefined property: stdClass::$db”. This seems to be a know problem (

I just noticed that was available through virtualmin. The release notes looked promising but the problem is still there.

I upgraded to phpmyadmin 4.4.2 via virtualmin but still saw the problem. The latest update to suggests that a fix has been identified and will be available in phpmyadmin 4.4.3.

Upgraded to 4.4.3 via virtualmin, Browse problems gone.