Virtualmin virtual-server module version 4.11 released

Howdy all,

I’ve just rolled out version 4.11 of Virtualmin virtual-server module for all repos. I believe this (along with the newest fixes all known CentOS 7 installation and initial configuration issues with Virtualmin.

Changes since 4.10:

  • Updated the phpMyAdmin script installer to version, and, Moodle to 2.7, Wordpress to 4.0, PiWik to 2.6.1, X2CRM to 4.2.1, FengOffice to, Node.JS to 0.10.32, and Django to 1.4.15 and 1.7.
  • If Dovecot 2 or higher has SSL enabled, the certificate for domains with a private IP address will be used for connections to the Dovecot server.
  • IPv6 addresses in Virtualmin are now supported on all operation systems that Webmin supports them for, rather than just Linux.
  • Automatic cleanup of messages in all mailboxes and folders can now be setup in Virtualmin, to enforce an email retention policy or save on disk space.
  • If Postfix and Dovecot are setup to use SSL, they will be configured to use the certificate belonging to virtual servers with their own private IP address for connections to that IP.

As always, let us know if you spot any bugs. There’s some new features in this one, in addition to the CentOS 7 support fixes, so the likelihood of bugs is higher than bugfix and stability releases.

I created a support request, but thought I’d post here also - I ran this update and it took me from 4.10 gpl to 4.11 pro

I am fine with gpl, is there a way to go back… ?

I can confirm that my dedicated server now has the 4.11 Pro version. I’m positive this was not intended and I won’t mind losing the extra functionality after the fix :slight_smile:

Hi I’m just upgrade 20+ VM’s and the Ubuntu-12 boxes went to 4.11pro the centos-6 boxes seem to be at gpl

On CentOS 7 it installs with no issues and reports as “Virtualmin version 4.11.gpl GPL”

Yep, that was my fault. I ran my “copy this to all the Debian/Ubuntu GPL repos” script in the wrong directory…that’s what I get for doing a software release at the end of a long day.

It should be fixed now, and a new version 4.11.gpl-2 should be in the repos which will replace the Pro version. The Pro version would give license errors, eventually, but it won’t harm anything to have installed it temporarily. I haven’t tested this, as I don’t have an Ubuntu/Debian system handy that got the problem package, and I’m focused on making sure we haven’t been effected by the bash bug on any of our servers right now, so won’t be able to test until tomorrow morning.

Thanks for the update Joe, please post after your Ubuntu test - I’ll hold off until then re-updating.

EDIT: Just ran the update - back to GPL as expected. Everything seems normal.

My Virtualmin Pro got converted to GPL.
I had to reactivate pro again, and activate the pro features like status monitoring.


Since the update, I cannot connect to my Imap server with SSL anymore. Without SSL it works fine but with it doesn’t.

I have several virtual server on my server and no one can connect with SSL anymore…


Since the update, I cannot connect to my Imap server with SSL anymore. Without SSL it works fine but with it doesn’t.

I have several virtual server on my server and no one can connect with SSL anymore…

Do you have an idea why ?


There shouldn’t be anything in updating Virtualmin that would cause SSL for one of your services to stop working.

We’ll need do some troubleshooting and otherwise dig into things a bit – with that in mind, you may want to open up a new Forum post regarding this issue, so we can keep the topics separate.

When opening a new Forum post, let us know what distro/version you’re using, as well as what shows up in the mail logs when trying to connect to IMAP via SSL.

Also, let us know what the output of this command is:

netstat -an | grep :993

Put all that info into a new Forum post though, that will make it easier for us to assist.



My problem has been resolved… The last update need a reboot and, for a reason I don’t know, the firewall didn’t start at boot. And the port 993 wasn’t opened…

Sorry and thanks for your time !

Could someone let me know how this was done? I was downgraded to GPL and can’t seem to get back.

We’re sorry that you’re seeing this issue – we had a problem with the repository.

You can correct that by running this command:

apt-get install webmin-virtual-server=4.11-3

That will install the current version of Virtualmin Pro.


That worked. Thanks for the quick support!