Virtualmin virtual-server module 6.17 released

Howdy all,

I’ve rolled out Virtualmin virtual-server module for all repos.

Changes since 6.16:

  • Added a field to the virtual server creation page to use an existing SSH key for logins, or generate a new key.
  • If needed, Virtualmin will configure the exact PHP version required to run scripts when installed.
  • Two-factor authentication for Usermin is setup for domain owners at the same time as Virtualmin.
  • Added the create-login-link API command to login as a domain owner without a password.
  • Massively simplified the SSL Certificate page for services certificates.
  • Added a field for entering an SSH private key file for use in backups, instead of a password.

Pro also includes a number of new cloud DNS providers (in addition to Route 53 support that’s already been in for a while), including Cloudflare and Google Cloud DNS, which is a preview of features to come in Virtualmin Pro version 7. These are very large new features, and should be considered beta…don’t rely on them in production until you thoroughly test your use case, but do let us know if you find any bugs.

As always, let us know if you run into any problems.



Can you help point me to the right direction?
I am faced with this error while trying to create virtual server

Undefined subroutine &virtual_server::check_domain_connectivity called at /usr/libexec/webmin/virtual-server/ line 8068


Undefined subroutine &virtual_server::check_domain_connectivity called at /usr/libexec/webmin/virtual-server/ line 8068.

Job for certbot-renew.service failed because the control process exited with error code.
See “systemctl status certbot-renew.service” and “journalctl -xe” for details.
Site I need help with is

I also encountered this error and came here looking to see if anyone had already reported it.

When creating a virtual server with both web SSL site enabled, it fails with that error right before attempting to obtain a Let’s Encrypt certificate:

Requesting a certificate for from Let's Encrypt ..

HTTP/1.0 500 Perl execution failed Server: MiniServ/1.981 Date: Tue, 21 Sep 2021 18:16:11 GMT Content-type: text/html; Charset=utf-8 Connection: close

Error — Perl execution failed

Undefined subroutine &virtual_server::check_domain_connectivity called at line 8068.

What I was able to do to work around this issue, is to create the server without the SSL server enabled. After it is created, then select “Edit virtual server” and enable the SSL feature. After that change is saved, you can go to the SSL Certificate option under Server Configuration, select the Let’s Encrypt tab, and request the certificate there. This worked for me.

I hope it works for you as well.

Ok. Let me try your workaround and see if I will be lucky on that. I will report back soon. Thanks

Can y’all open a new topic about this issue and include your OS and version?

Thanks! I already did that but no response yet. See here Thanks

No luck on this work around

As always thanks so much for the amazing work done with every Virtualmin release! Just a suggestion, can Linode’s cloud DNS service be added to this list for those customers who use Linode servers? Linode has an API that can be used for DNS transactions. See Domains | Linode


I tried to upgrade from Virtualmin virtual-server module version 6.16 to version 6.17 by logging into Webmin 1.981, opening Webmin Configuration/Upgrade Webmin, selecting the Update modules tab, selecting the “Update from other sources” radio button, entering “” into the text box, leaving only the default Module update options “Only show which modules would be updated” checkbox checked to start, and then clicking the Update Modules button. Webmin returned “Updating Webmin modules … No Webmin updates for this version.” I expected to see that the Virtualmin module would be updated. Since this did not happen, I decided to report this in reply to the release announcement before trying anything else. Please let me know whether the error is mine or is caused by a bug, and any recommended next steps. Thanks in advance.


The system specifications as reported by Webmin are:
Webmin version: 1.981
[Webmin Installer:]
Virtualmin version: 6.16
Authentic theme version: 19.83-2
Kernel and CPU: FreeBSD 12.2-RELEASE-p7 on amd64
Perl version: 5.032001
Path to Perl: /usr/local/bin/perl
Python version: 3.7.10
Path to Python: /usr/local/bin/python3.7
Postfix version: /usr/sbin/sendmail -t
Apache version: 2.4.49
PHP versions: 8.0.10
Webalizer version: 2.23-08
Logrotate version: 3.13.0

I haven’t seen that page in over a decade (we disable the Upgrade Webmin feature in Virtualmin installs when a package manager is used, to prevent people from breaking their systems by intermixing wbm with proper dpkg or rpm packages).

But, I know that’s ( not a proper source. A wbm package source is just the URL up to /wbm…not including the filename. That module is trying to download a list of available versions, not a package.

If you want to install a wbm directly from a full URL, use the Webmin Modules page.

The error message in your screenshot looks like you were rate limited (probably due to attempts that didn’t complete). Since it’s been some time since you tried it yesterday, maybe if you give it another go it will complete. Worth a shot.

No luck yet.

Requesting a certificate for,,,, from Let's Encrypt ..
HTTP/1.0 500 Perl execution failed Server: MiniServ/1.981 Date: Thu, 23 Sep 2021 03:48:50 GMT Content-type: text/html; Charset=utf-8 Connection: close
Undefined subroutine &virtual_server::check_domain_connectivity called at /usr/libexec/webmin/virtual-server/ line 8068.

This will be fixed in a 6.17-2 release, hopefully rolling in a few minutes. There was a tagging mishap where we rolled out the wrong commit from git. This bug was already fixed, but it didn’t make it into the package.

Er, scratch that, I’m not going to be able to finish packaging and deploying tonight. Will get it into the repos in the morning.

1 Like


Thanks for your reply. I initially used the Webmin Modules page to install the Virtualmin Virtual Servers module. Since I now need to update the already installed module, if I use Webmin Modules again should I first delete the Virtualmin Virtual Servers (v. 6.16.gpl) module that is currently installed before installing version 6.17? I presume that if I first delete the currently installed module that I will need to manually preserve and reinstall /usr/local/etc/webmin/virtual-server/config. I am concerned that if I just install version 6.16 over version 6.17 using the Webmin Modules page that many obsolete and unused files could be left behind after the update. I had thought that the Update modules tab of the Upgrade Webmin page would be a better tool for performing module upgrades since I expected it would delete installed files not replaced by the new version, except for the config file of course.

I should note that I stopped using the packaged versions of Webmin and Virtualmin for FreeBSD because the version updates were often untimely and I discovered after many wasted hours that the default VIrtualmin config file included in the package was incomplete which prevented Virtualmin from functioning properly. Also, when the packaged version of Webmin is installed, it still offers to update itself when new versions are released. If this is allowed, then a mess is left behind. Until a new packaged version of Webmin is released and installed or a tedious workaround is performed, FreeBSD periodically reports a long list of mismatched and missing files from the previous packaged version. Installing Webmin and Virtualmin directly from the official repositories avoids these problems, is almost as easy as using the FreeBSD packages, and enables Webmin to update itself without any problems.

I initially tried entering “” into the Update modules tab of the Upgrade Webmin page. That returned “Updating Webmin modules .. Failed to update modules : Invalid module updates source file” which is why I then tried the full URL including the file name. The wbm directory now contains new files named “webmin-version” and “usermin-version” which contain only the current version numbers. There is no file named “virtual-server-version” or anything similar. There is another new file named “updates.txt” which contains only “virtual-server 0 Latest version” which I suspect is the file that Update modules reports as invalid. I am wondering whether a different version of the “updates.txt” file would enable the Update modules tab of the Upgrade Webmin page to be used to update the Virtualmin Virtual Servers module correctly.

I hope that you find this feedback helpful.



No! NO! Never!

Why would you think that would be necessary or useful?

As I wrote, “I am concerned that if I just install version 6.16 over version 6.17 using the Webmin Modules page that many obsolete and unused files could be left behind after the update.”

You shouldn’t have that concern.

Apart from the mentioned CF and GC, who else is there? Might be worth paying for (even though I should really consider that anyway now) :slight_smile:

Looks like it is currently just Cloudflare and Google Cloud DNS (and Route 53 which is, for some reason, already available in GPL…that reason is because we can’t seem to even want to try make a little money, I guess).

Mail is also getting a cloud overhaul (making it easier/more automated to use, e.g. Google Suite for mail), though it may not be finished yet.