Virtualmin virtual-server 3.52

Howdy all,

I’ve just released Virtualmin virtual-server 3.52 to the repositories for all systems.

Changes since 3.51:

[li]Updated the Horde script installer to version 3.1.6, and the versions of several other Horde-related scripts.[/li]
[li]Updated the Drupal installer to versions 5.7 and 4.7.11, OpenAds to 2.4.3, Mantis to 1.1.1, Joomla to 1.5.0, TWiki 4.2.0, Movable Type to 4.1, WordPress MU to 1.3.2, osTicket to 1.6.rc3, Nucleus to 3.32, Coppermine to 1.4.16, Plans to 7.9.9, ZenPhoto to 1.1.4, Bugzilla to 3.1.3, TextPattern to 4.0.6, and phpMyAdmin to 2.11.4.[/li]
[li]When restoring a virtual server that uses features not supported on the system, a warning will be displayed listing the missing or disabled features.
Custom styles can use the nocontent=1 line in to specify that no initial content needs to be entered.[/li]
[li]When moving a virtual server to a new system via a restore, if any required PHP modules that were installed on the old system are missing on the new, they will be automatically installed (where possible). In addition, you will be notified if any required PHP versions are missing.[/li]
[li]When editing a virtual server without a private IP address, one can be added that is associated with an existing interface on the system.[/li]
[li]When a domain is restored to a system with a new IP address, the IP in the SPF record is updated. Also, any NS records are updated to match the new system.[/li]
[li]When a virtual server is moved under a new owner, the Apache directives that control which user CGIs and PHP scripts run as are properly updated.
Fixed bugs in the FAQMasterFlex installer that prevented it’s config file from being setup properly.[/li]
[li]Re-wrote all code that locks configuration files managed by Virtualmin. This improves the coverage of Webmin logging, and makes it much safer to perform multiple operations on the same or different domains at once.[/li]
[li]Outgoing email relayed via the Virtualmin system is now counted towards the sender’s domain’s bandwidth limit, unless disabled on the Bandwidth Monitoring page.[/li]
[li]Moved the option that controls if mailbox users can have .procmailrc files to the Spam and Virus Delivery page, where it is easier to find and is applied immediately.[/li]
[li]The wrapper scripts for running PHP via CGI or fastCGI now have the immutable flag set on Linux, to prevent accidental deletion by domain owners.[/li]
[li]New features in this version of Virtualmin and any plugins are shown on the System Information page, if using the Virtualmin theme.[/li]

Comprehensive locking is the most important change in this update, and reaches into every corner of Virtualmin code–we believe all bugs in these changes have been squashed during QC and rollout to GPL users, but let us know if you see anything fishy, particularly file corruptions when Virtualmin is in use by many simultaneous users.

Joomla is available in 1.0.14 and 1.5.1 now :wink:

Looks Like the update of Virtualmin wiped out my DNS records…or could have been the new wbm-virtualmin-slavedns module not sure.

The Info page on the server…System Info shows that DNS is not running and will not restart with error – Failed to start service : Failed to start BIND : Starting named: named: already running[FAILED]

I have gone and looked at the Webmin/Bind Server tab and it is not running there, but there is a PID file at /var/run/named/

Also, when testing my DNS with nslookup -->server
[freebrew@ns1 ~]$ nslookup
> server
Default server:

Address: 68.XXX.XX.202

Address: 68.XXX.XX.202
Not sure what to do…

How is DNS not running but still returning records with nslookup.

Please Inform Me

freebrew Out

We just had the same thing happen on our two CentOS 5.1 servers (two virtualmin keys). Not sure what the answer is to get this mess fixed.

[size=3][color=#000080]Same here - bind fails to startup with :

Failed to start service : Failed to start BIND : Starting named: named: already running[FAILED]

the domains can not be removed or restored via virtualmin either
delete one domain and it says unable to write to directory.
i have removed all my domains and recreated them with no difference at all.[/color][/size]
[size=4][color=#FF6600]Any ideas??[/color][/size]

Okay the Answer to the BIND Error.

To fix it, [color=#FF6600]go to the BIND DNS Server module, click on Module Config and make sure the ‘Chroot directory to run BIND under’ is set correctly, and the ‘Command to find chroot directory’ is set to ‘Use fixed directory’[/color].

Thanks [color=#FF0000]Jamie.[/color]

I changed the config setting to fixed directory and disabled Chroot directory to run BIND under (or none)

[color=#008000]It fixed it for me!!! [/color]thank god.


Sorry forgot to mention that its the bind config in webmin you need to change (webmin tab > Servers > Bind DNS > bind config)

I just installed this release on a fresh CentOS 5 install and I’ve had nothing but problems. CentOS is suppose to be the premiere supported OS too. The install/setup script is worthless, it didn’t setup any of the services and service configs! And now I have licensing issues after a fresh install. Is there anyway to downgrade to 3.51?

Jamie said in a different thread in the VirtualMin sub forum, there will be a new release to fix this issue. If you can hold on, I’m sure there will be a fix pretty quickly. (I’m just a customer though, not an official source of information. I don’t know exactly how soon. )

There is a fix on my post above if you want one!

Hey Guys,
I’m crossposting from the VirtualMin sub forum, in the hopes it helps someone.

I was formulating a reeeely, reeeely complex question, when I saw that jamie had the webmin 1.401-1 update out there. I installed it on my Centros 5.x server and it fixed the Webmin BIND display problem. I noticed that it did not change any of the settings in the Webmin’s Bind DNS->Module Config .

It’s that Systems Guru Kunfu black art.

Is there anyway to downgrade to 3.51?

None of these issues is related to the Virtualmin virtual-server module. All of it is related to the new version of Webmin. The BIND issue has been corrected by the 1.401 Webmin release rolled out over the weekend. The installation issue is also due to the Webmin release, but has only been corrected today by a new version of virtualmin-base (which performs all of the configuration steps during installation).

To correct a botched install on CentOS, do the following:

rpm -e virtualmin-base
yum install virtualmin-base

I believe this will straighten everything out. (Also, make sure you have Webmin 1.401, rather than 1.400. "rpm -q webmin" will tell you.)

the joomla 1.5 installer is not working!
maybe a wrong link?
Error msg:
Failed to install script : Download of failed : Invalid Location header /gf/account/?action=Login&redirect=%2Fgf%2Fdownload%2Ffrsrelease%2F5078%2F21064%2FJoomla-1.5.0.tar.gz

version 1.13 is working.

please resolve it.

Joomla 1.5.1 lovers rejoice! You don’t have to wait till Virtualmin 3.53+. Here’s my working install script until Vmin 3.53 comes out.

All I did was update the version number, and the download URL’s.

Copy this file into the /usr/libexec/webmin/virtual-server/scripts directory, and you are good to go!

Note, this is a brute force hack. I doubt it works for non-english users. Lo Siento! (I’m sorry!)