VirtualMin virtual mail server problem


We are trying to create mail server on a seperate server for our domain.
Currently is pointed to our webhoster where the website is located. We would like to have the MAIL (only mail) pointed to an OVH VPS Server running webmin/virtualmin/postfix.

We have created an A record pointing and to the OVH VPS IP (and also set the MX record of to point to

Have tried to add,, and as virtual server through virtualmin panel - and added a couple of email user accounts, but doesn’t seem to work. Always get Relay access denied or ‘looping back to myself’ - depending on the settings I adjust in postfix’s

(PS! Pointing the entire to OVH VPS IP, creating virtual server and then creating mail accounts works just fine!)

Here is the Postfix

See /usr/share/postfix/ for a commented, more complete version

Debian specific: Specifying a file name will cause the first

line of that file to be used as the name. The Debian default

is /etc/mailname.

#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

appending .domain is the MUA’s job.

append_dot_mydomain = no

Uncomment the next line to generate “delayed mail” warnings

#delay_warning_time = 4h

readme_directory = no

TLS parameters

smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for

information on enabling SSL in the smtp client.

myhostname =
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination =,, localhost
relayhost =
mynetworks = [::ffff:]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_maps = hash:/etc/postfix/virtual
virtual_mailbox_maps = hash:/etc/postfix/virtual_mailbox_maps
sender_bcc_maps = hash:/etc/postfix/bcc
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
home_mailbox = Maildir/
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
allow_percent_hack = no
message_size_limit = 25000000
smtpd_sasl_authenticated_header = yes

Any help is appreciated. Thanks!


If you’d be open a screen sharing session, I’d be happy to assist you in resolving this matter.

Just send me a message on Skype, or email me should you be interested in the assistance.

Best Regards, Peter Knowles TPN Solutions

Phone: 604-229-0715 (new)
Skype: tpnsupport

Damn, this guy, Peter Knowles, is a genius :slight_smile:

He helped me out to fix the problem.
Going through all of the configuration files on the server, checking DNS settings, MX settings, seeing through that all configuration was done correctly.

He even went through the client settings (where the problem was…!) and fixed the issue.
Client setup was NOT setup to authenticate when SENDING mails. In Live Mail client, this setting is marked as
“My server requires authentication” – checked this, and issue resolved.

Many, many thanks to Mr. Knowles. He knows what he is doing, is very friendly.
Recommend him to anyone having issues :slight_smile: