Virtualmin update

Just updated Virtualmin and webmin.

I´ll get the statuspage.
The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 512 MB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.
BIND DNS server is installed, and the system is configured to use it.

No sender canonical map file for outgoing addresses was found in your Postfix configuration. You should either add the appropriate map to Postfix, or disable this feature in Virtualmin’s module config page.

… your system is not ready for use by Virtualmin.

As a newbie, what do i do?



It sounds like a feature had somehow been enabled that requires a little additional tweaking. It should be a simple fix though, try running these two commands as root:

touch /etc/postfix/canonical postmap /etc/postfix/canonical

And after that, re-run the Virtualmin config check and see if everything checks out okay.


I’ve tried to run the commads as root through PuTTy but it did not help.
Am i doing something wrong?

Ah, it looks like you would also need to add this line to /etc/postfix/

sender_canonical_maps = hash:/etc/postfix/canonical

And then restart Postfix:

/etc/init.d/postfix restart

Once you do that, that should do the trick! Let us know how that works for you.


Sorry but as a total newbie i’m not sure what to do.
I’m trying to run these commands in PuTTy. is that the right think to do?
Shall i run them all after each other?

When i’m trying to run /etc/postfix/ it says “no such file or directory”

Please tell me in steps what to do, or maybe tell me if there is somewhere i can read about it

Thank you


The file “/etc/postfix/” is text file that you need to edit… so you wouldn’t run it, you would edit it. Do you have a text editor you use?

If so, you can open up that text editor, edit the file, and then go to the end and add this line:

sender_canonical_maps = hash:/etc/postfix/canonical

Sorry for all these q. Is there anywhere i can read about the postfix?

I’ll try these suggestion, but where do i find the file to edit.

Is there a way to add the appropiate map to Postfix in the configuration instead?


Is there anywhere i can read about the postfix?

Well, there is Postfix documentation at, but I’m not sure that’ll provide what you’re looking for…

I’ll try these suggestion, but where do i find the file to edit.

The file you want to edit is the “/etc/postfix/” file I mentioned above – so you’d need to log into your server as root, go into the “etc” directory, then into “postfix”, and then edit “”.

After that, add this to the end of that file:

sender_canonical_maps = hash:/etc/postfix/canonical

And then run this command to restart Postfix:

/etc/init.d/postfix restart

Now made the changes you wrote to and i’m now getting this message:

Your Postfix configuration is missing the system’s mail hostname mofpevps from the mydestination line, which will cause mail to bounce.

What is that?

Out of curiosity – how did you go about installing Virtualmin, did you by chance use the script?

On a typical installation, that’s automatically set for you during the install process.

However, what it’s saying is that you need to edit that /etc/postfix/ file again, look for the line beginning with “mydestination”, and add “mofpevps” to the end of that line.


Hey it worked.

Thank you very much for all your patience. :slight_smile:

Sorry, forgot to tell you that i installed virtualmin via the script.

The problems with the canonical first came after i updated virtualmin to 3.92