Virtualmin update problem

Hi,

After updating the system and the virtualmin to the latest version after a checking of the system i have the following error:

  SpamAssassin is configured to be run from the global Procmail configuration /etc/procmailrc, which is not needed as Virtualmin will set it up on a per-domain basis.

… your system is not ready for use by Virtualmin.

I am using CentOS 5.2

wbt-virtual-server-theme-6.2-1
ust-virtual-server-theme-6.2-1

How can i fix this issue?
Thanks

Which Virtualmin version do you have installed now?

rpm -qa | grep virtual-server

Thanks,
-Eric

Hi,

This is the output

wbt-virtual-server-mobile-1.8-1
ust-virtual-server-theme-6.2-1
wbt-virtual-server-theme-6.2-1
wbm-virtual-server-3.62.gpl-1

Mmm, ok, what are the contents of /etc/procmailrc?
-Eric

The error means you used the Webmin SpamAssassin module to configure procmail to scan mail–which conflicts with Virtualmin’s method of managing mail.

You need to remove the rules that the Webmin module added. They look something like this:

:0

  • ^X-Spam-Status: Yes
    $HOME/Maildir/spam/

I suspect it’s referring to the call to spamassassin:

[code:1]
:0fw
| /usr/bin/spamassassin
[/code:1]

What I would do is comment out the above two lines, and put LOGFILE and TRAP at the top of the file.
-Eric

Seeing something similar. spam filtering broke over night. very weird. centos 5. I have a broken arm, so doing some slow 1-handed investigation :slight_smile:

-m

oops cant edit a post…

note my procmailrc hasnt changed in 6 months

fixed.

  1. removed following from /etc/procmailrc

| /usr/bin/spamassassin
:0

  • ^X-Spam-Status: Yes
    $HOME/Maildir/.spam/[/code:1]
  1. Virtualmin -> System Settings -> Features and Plugins
    enable spam

  2. reload vm page to get next link

  3. email messages -> spam and virus
    turn it on, enable clamav server

  4. webmin -> servers -> spamassassin -> procmail
    qmail style to $HOME/Maildir/.spam

-m

Thanks,

After commenting the [code:1]
:0fw

| /usr/bin/spamassassin[/code:1] problem was solved.

Thk Again

Hello,

I made the changes to the /etc/procmailrc but still the same problem:
here is the old config:

[code:1]DROPPRIVS=yes
:0fw
| /usr/bin/spamassassin
:0

  • ^X-Spam-Status: Yes
    $HOME/spam
    LOGFILE=/var/log/procmail.log
    TRAP=/etc/webmin/virtual-server/procmail-logger.pl
    :0wi
    VIRTUALMIN=|/etc/webmin/virtual-server/lookup-domain.pl $LOGNAME
    :0
  • ?/usr/bin/test "$VIRTUALMIN" != ""
    {
    INCLUDERC=/etc/webmin/virtual-server/procmail/$VIRTUALMIN
    }
    DEFAULT=$HOME/Maildir/
    ORGMAIL=$HOME/Maildir/
    DROPPRIVS=yes
    :0
    $DEFAULT
    [/code:1]

and here is the modified code:

[code:1]DROPPRIVS=yes
:0fw
| /usr/bin/spamassassin
LOGFILE=/var/log/procmail.log
TRAP=/etc/webmin/virtual-server/procmail-logger.pl
:0wi
VIRTUALMIN=|/etc/webmin/virtual-server/lookup-domain.pl $LOGNAME
:0

  • ?/usr/bin/test "$VIRTUALMIN" != ""
    {
    INCLUDERC=/etc/webmin/virtual-server/procmail/$VIRTUALMIN
    }
    DEFAULT=$HOME/Maildir/
    ORGMAIL=$HOME/Maildir/
    DROPPRIVS=yes
    :0
    $DEFAULT
    [/code:1]

Is possible that i`m missing something

Hello,

I made the changes to the /etc/procmailrc but still the same problem:
here is the old config:

[code:1]DROPPRIVS=yes
:0fw
| /usr/bin/spamassassin
:0

  • ^X-Spam-Status: Yes
    $HOME/spam
    LOGFILE=/var/log/procmail.log
    TRAP=/etc/webmin/virtual-server/procmail-logger.pl
    :0wi
    VIRTUALMIN=|/etc/webmin/virtual-server/lookup-domain.pl $LOGNAME
    :0
  • ?/usr/bin/test "$VIRTUALMIN" != ""
    {
    INCLUDERC=/etc/webmin/virtual-server/procmail/$VIRTUALMIN
    }
    DEFAULT=$HOME/Maildir/
    ORGMAIL=$HOME/Maildir/
    DROPPRIVS=yes
    :0
    $DEFAULT
    [/code:1]

and here is the modified code:

[code:1]DROPPRIVS=yes
:0fw
| /usr/bin/spamassassin
LOGFILE=/var/log/procmail.log
TRAP=/etc/webmin/virtual-server/procmail-logger.pl
:0wi
VIRTUALMIN=|/etc/webmin/virtual-server/lookup-domain.pl $LOGNAME
:0

  • ?/usr/bin/test "$VIRTUALMIN" != ""
    {
    INCLUDERC=/etc/webmin/virtual-server/procmail/$VIRTUALMIN
    }
    DEFAULT=$HOME/Maildir/
    ORGMAIL=$HOME/Maildir/
    DROPPRIVS=yes
    :0
    $DEFAULT
    [/code:1]

Is possible that i`m missing something