Virtualmin system email

i have a question, it may have an obvious answer but i have looked all over any possible configuration area to find the answer. my problem well not really its more like a convenience. anyways, the emails that the server sends out that someone’s account has been created is sent under the name of the host-name of the server. the localhost name. like webmin@linux-server. is it possible that i could send it under my name or just change the @ending to my website address. i like webmin@ thats fine i just want to change the domain.

one other question. is it possible to change the address redirect link when someone types the address of the server in an unsecured fashion. to the actual domain name of the website like from this https://192.168.1.8:10000 to https://www.mydomain.com:10000.

this is such a cool system i really love it

any help would be much appreciated. thank you

Hi

1- This may be help you: http://rpgoldman.real-time.com/linux/postfix-linux.html

"…

  1. Set up main.cf to have canonical addresses. Add the following line to /etc/postfix/main.cf:
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
  2. Set up the table of canonical addresses. In the file /etc/postfix/sender_canonical, put a line like the following for each local user account:
    username ISP account name@ISP
    So, for example, I might have:
    rpg rpgoldman@bletcherous.isp.com
    Of course, the address you put here must be a valid email address for an account you read!
    New item: I find it’s also helpful to add a sender address rewrite for root to be my personal email address as well:
    root rpgoldman@bletcherous.isp.com
    This helps me trap and debug cases where mail from root is leaking out of my network.
  3. Run
    postmap /etc/postfix/sender_canonical
    to create the map file, /etc/postfix/sender_canonical.db.
    …"

-> you can add a line like: webmin@yourhostname webmin@domain

2- http://readlist.com/lists/lists.sourceforge.net/webadmin-list/1/7080.html

"… Because Webmin can’t get the hostname that was in the original HTTP request, it has to punt and do a reverse lookup of the connected-to IP address to get a hostname for the URL. If this is incorrect, you have two choices :

Fix the reverse DNS entry (probably difficult, as it may be controlled by your ISP).

Add a line to /etc/hosts on the Webmin system like :
11.22.33.44 your.correct.hostname.com …"

I recommend you the first option since you need anyway the reverse DNS entry with your hostname to be able to send mails to all servers.<br><br>Post edited by: acid, at: 2008/01/17 09:26