virtualmin stopped loading in Debian 7 - Amazon EC2

Dear Team,

I have installed virtualmin in an AWS EC2 Instance running Debian 7

AWS Public DNS : ec2-54-229-72-123.eu-west-1.compute.amazonaws.com

Elastic IP : 54.229.72.123

I have been successfully using virtualmin to migrate some 30 cpanel accounts.

All of a sudden, virtualmin admin page stopped loading.

Tried both

https://54.229.72.123:10000

and

https://ec2-54-229-72-123.eu-west-1.compute.amazonaws.com:10000

Tried rebooting AWS EC2 instance and entered

/etc/init.d/webmin restart

not result.

Please help.

Thanks and Regards

Howdy,

What output do you receive if you run this command:

netstat -an | grep :10000

Hello,

I tried twice in ssh. But no output

root@ip-172-31-6-196:~# netstat -an | grep :10000
root@ip-172-31-6-196:~# netstat -an | grep :10000

Howdy,

Okay, that suggests that Webmin isn’t running.

What output do you receive if you run this command:

/etc/init.d/webmin start

Also, do you see any errors in /var/webmin/miniserv.error?

-Eric

Hello Eric,

I ran

/etc/init.d/webmin start

there was no output, but virtualmin started loading to my relief :slight_smile:
But virtualmin works only for very few minutes and again stops loading.

If i again enter

/etc/init.d/webmin start

it starts loading

I have attached the contents of the file

/var/webmin/miniserv.error

There was one suggestion in that file asking me load
https://172.31.6.196:10000
I tried that, but no use.
172.31.6.196 is my private ip

I am sure that you are guiding me in the right direction
Please help me in resolving this issue permanently.

Thanks and Regards

Team

/etc/init.d/webmin start

command helped me start virtualmin twice and it was loading for a few minutes and then again started showing a blank screen.

Now even the command
/etc/init.d/webmin start
is not working, as inspite of executing the above command as root user, virtualmin not loading.

Please help.

Thanks and Regards

Howdy,

Hmm, what output do you see if you run the command “dmesg | tail -30”?

Also, if you look in /var/log/kern.log, do you see any unusual errors?

-Eric

Hello Eric,

I have enclosed 2 reports as requested by you.

error-1.pdf dmesg | tail -30

error-2.pdf contents of /var/log/kern.log

When i reboot the server, virtualmin loads for a few minutes and then shuts down.
That, clearly is not the solution.

Please help.

Thanks

Hello,

mysql server also fails to start :frowning:

root@ip-172-31-6-196:~# /etc/init.d/mysql start
[FAIL] Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!

Please help as my entire set of domains are down :frowning:

thanks