virtualmin + ssl problem

hello
i’ve 6 ip’s.
i have eth0 with the main ip and 5 vlans.
like eth0 and eth0.1 - eth0.5.
my apache is atm only listen on the main ip and only on port 80.
i’ve added the ranges xx.xx.xx.x1 - xx.xx.xx.x5 (for example) in the template for new virtual servers.
i’ve added these ips to the shared ip section too.

the same problem.
if i try to add a new server and i check create ssl website too and i check Virtual with allocated IP i become everytime this error: Failed to create virtual server : Could not allocate virtual IP address from range.

if i use shared ip i become this: Failed to create virtual server : SSL cannot be enabled unless a virtual IP interface or private port is enabled.

i dont know why but virtualmin don’t want any of my other ips.

can anyone say me what i do wrong?
it is my first time with apache and ssl.
and i think virtualmin looks for a free virtual ip to use.
or is there a edit box where i can paste a ip? (i could see a box).

these ips are real ips (no local only ips).
i don’t know what i do wrong :frowning:

i’m running webmin 1.340 and virtualmin 3.39 on a gentoo box.

thx for help

Hi Chris,

I have 6 ip’s to on my box.

I DO NOT enter those IP that I use for SSL in the shared list.

When I create a new SSL server I use this option in "Network interface" section:
(o) Virtual with IP [[x.x.x.x]] ( [[X]] Already active )

I have all IP’s active, so I tick the box.

This works for me, as long as I don’t list those ip’s that I vant to use for SSL in the shared list.

Regards,
Leif

i hav’t this edit box to enter a virtual ip.
look here: http://img105.imageshack.us/img105/5632/virtualminez5.png

is it a bug?
i’ve installed virtualmin via webmin.

Hi,

I’m using Virtualmin Pro, guess you are using the GPL version.
I don’t know how the GPL version looks/works.

Hopefully Joe or Jamie can help you out here.

Regards,
Leif

In case it is urgent:
/usr/local/apache2/httpd.conf
(or apache2.conf)
Or whereever you installed apache.
Edit the config for the virtual hosts,
copy the virtualhost of virtualmin for the domain name without ssl.

Ip & port is obliged.

  • als ip does not work for SSL certificates.

< virtualsomething xxx.xxx.xxx.xxx:443]
Servername blablabla

SSLenabled On
SSL key
SSL other file

< /virtualsomething]

This should get it working rather quickly this way.
You do have mod_ssl installed in apache, don’t you?

I always enable SSL manually, because virtualmin (gpl) isn’t very clear about these kind of things. :wink:

i hav’t this edit box to enter a virtual ip.

I seem to recall that there was such a bug…in older versions of the software. Upgrade to 3.39, and I believe you’ll be fine.

i use 3.39

ok i’ve added these things by hand but i wish to change some settings via virtualmin but i can’t.
if i want change ssl settings i must do this by hand.
virtualmin dosn’t let me change these things.

i hope this bug will be fixed in the next version.

hey chris,

i’ve been workin on a similar project, using ip-alias to create multiple ssl vhosts on one machine. i get the different aliased ip’s working correctly (each with their own certificates if i https://ipAddr).

i’m stuck trying to create a secure proxy between eth0:0 and the other aliases, have you found a way to do this?

i’m not sure if a stunnel is needed or just a perment sslProxy, but keeping the reverse lookup names for the vhosts is driving me crazy.

i’ve added ssl by hand for some ip’s.
my only problem now is that i can’t change some ssl based settings via webmin/virtualmin.

and another thing is that virtualmin puts new mail addresses (by server creation) in the mysql file for virtual users.
so i must disable this by default.

i hope that anyone fixes the ssl problem in the gpl version.
i use virtualmin only private and i don’t have much money to buy a lot of commercial software to get successfully issues.