Virtualmin Signup Email Not Sending

Hello All,

I am setting up a Virtualmin server and am having issues with the signup email. I can’t get it to send. I can’t seem to figure it out. I have tried doing mail relaying (thinking that may help, I possibly may have something msconfigured.)

Any help is greatly appreciated.

One the other hand if anyone know a way to administrate an IceCast streaming server using Webmin/Virtualmin that would be much appreciated as well. I have googled endlessly (apprx. 4-5 hrs.).

Thanks in Advance,

Phill F


My suggestion would be to check the mail logs, in either /var/log/maillog or /var/log/mail.log, and make sure you see it attempting to send the message.

If it is, is there an error message of some sort that you see there?

And sorry, I’ve never setup an icecast streaming server before :slight_smile:


Hey Eric,

This is what I see in my mail.log a few times over:

May 15 20:21:25 powercastmedia sendmail[12208]: p4G0LPId012207: to=root, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=34748, dsn=2.0.0, stat=Sent May 15 20:28:04 powercastmedia sendmail[12392]: p4G0S4Nf012392:, size=915, class=0, nrcpts=1, msgid=<>, relay=root@localhost May 15 20:28:04 powercastmedia sendmail[12393]: p4G0S4R0012393: ... User unknown May 15 20:28:04 powercastmedia sendmail[12392]: p4G0S4Nf012392:, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30915, relay=[] [], dsn=5.1.1, stat=User unknown

Still can’t figure it out.

  • Phill

Well, it looks like you have a relayhost of localhost setup… that may be compounding the problem :slight_smile:

You may want to try removing it, and see what error shows up at that point.

Also, you may want to try running System Settings -> Re-Check Config to see if it notices any problems.


Hello Eric,

Here is my sendmail config:


$Sendmail:,v 8.14.3 2010-08-03 06:56:05 cowboy Exp $

Copyright © 1998-2009 Richard Nelson. All Rights Reserved.

cf/debian/ Generated from by configure. prototype config file for building Sendmail 8.14.3

Note: the .in file supports 8.7.6 - 9.0.0, but the generated

file is customized to the version noted above.

This file is used to configure Sendmail for use with Debian systems.

If you modify this file, you will have to regenerate /etc/mail/

by running this file through the m4 preprocessor via one of the following:

* make (or make -C /etc/mail)

* sendmailconfig

* m4 /etc/mail/ > /etc/mail/

The first two options are preferred as they will also update other files

that depend upon the contents of this file.

The best documentation for this .mc file is:



Copyright © 1998-2005 Richard Nelson. All Rights Reserved.

This file is used to configure Sendmail for use with Debian systems.

define(_USE_ETC_MAIL_')dnl include(/usr/share/sendmail/cf/m4/cf.m4’)dnl
VERSIONID($Id:, v 8.14.3-9.2ubuntu1 2010-08-03 06:56:05 cowboy Exp $') OSTYPE(debian’)dnl
DOMAIN(debian-mta')dnl dnl # Items controlled by /etc/mail/sendmail.conf - DO NOT TOUCH HERE undefine(confHOST_STATUS_DIRECTORY’)dnl #DAEMON_HOSTSTATS=
dnl # Items controlled by /etc/mail/sendmail.conf - DO NOT TOUCH HERE
dnl #
dnl # General defines
dnl #
dnl # SAFE_FILE_ENV: [undefined] If set, sendmail will do a chroot()
dnl # into this directory before writing files.
dnl # If all your user accounts are under /home then use that
dnl # instead - it will prevent any writes outside of /home !
dnl # define(confSAFE_FILE_ENV', ’)dnl
dnl #
dnl # Daemon options - restrict to servicing LOCALHOST ONLY !!!
dnl # Remove , Addr=' clauses to receive from any interface dnl # If you want to support IPv6, switch the commented/uncommentd lines dnl # FEATURE(no_default_msa’)dnl
dnl DAEMON_OPTIONS(Family=inet6, Name=MTA-v6, Port=smtp')dnl dnl DAEMON_OPTIONS(Family=inet6, Name=MSP-v6, Port=submission, M=Ea’)dnl
dnl # Be somewhat anal in what we allow
define(confPRIVACY_FLAGS',dnl needmailhelo,needexpnhelo,needvrfyhelo,restrictqrun,restrictexpand,nobodyreturn,authwarnings’)dnl
dnl #
dnl # Define connection throttling and window length
define(confCONNECTION_RATE_THROTTLE', 15’)dnl
dnl #
dnl # Features
dnl #
dnl # use /etc/mail/local-host-names
FEATURE(use_cw_file')dnl dnl # dnl # The access db is the basis for most of sendmail's checking FEATURE(access_db’, , skip')dnl dnl # dnl # The greet_pause feature stops some automail bots - but check the dnl # provided access db for details on excluding localhosts... FEATURE(greet_pause’, 1000')dnl 1 seconds dnl # dnl # Delay_checks allows sender<->recipient checking FEATURE(delay_checks’, friend', n’)dnl
dnl #
dnl # If we get too many bad recipients, slow things down…
dnl #
dnl # Stop connections that overflow our concurrent and time connection rates
FEATURE(conncontrol', nodelay’, terminate')dnl FEATURE(ratecontrol’, nodelay', terminate’)dnl
dnl #
dnl # If you’re on a dialup link, you should enable this - so sendmail
dnl # will not bring up the link (it will queue mail for later)
dnl define(confCON_EXPENSIVE',True’)dnl
dnl #
dnl # Dialup/LAN connection overrides
dnl #
include(/etc/mail/m4/dialup.m4')dnl include(/etc/mail/m4/provider.m4’)dnl
dnl #
dnl # Default Mailer setup
FEATURE(mailertable',hash -o /etc/mail/mailertable’)

I am now sure if it is in there or somewhere else but I seem to be missing something.

Thanks Again,


Well, I’m unfortunately not really familiar with Sendmail… when the Virtualmin installer runs (the script), it would normally setup Postfix as the default mail server.

If you’re having problems, I’d suggest sticking with the default of Postfix, as you’d be less likely to have problems… and when problems do occur, we’d be better able to lend a hand :slight_smile:

Virtualmin is capable of working with Sendmail as the mail server, it just means that, rather than having all the mail server settings configured for you, that you need to manually get things working.


Hi Eric,

Thanks again for your help. I have switched to Postfix. Now I receive this error when I re-check my configs:

A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration

Screenshot of Transport Mapping:


Hrm, so how did you install Virtualmin – did you use the script?

It doesn’t sound like the Postfix config you have was configured by the installer.


This is actually running on a system that is not supported by the Virtualmin install script.

OS: Ubuntu 10.10 (Maverick Meerkat)

Virtualmin is running as a module on top of Webmin.

  • Phill

Aha… that’s the problem then :slight_smile:

You’re able to perform a manual install, but when doing that, you have to configure everything that the installer otherwise would have setup :slight_smile:

We highly recommend performing your installation on a Grade A supported Operating System… anything else will require a decent amount of setup work, and a lot of technical expertise.

If you’d like to stick with Ubuntu 10.10, that can work though. The manual setup instructions are available here:

You’ll want to review all of that – however, in particular for email, take a look at the Postfix, procmail, SpamAssassin, ClamAV, and saslauthd sections.