Virtualmin Restore error - "User...doesn't exist."

Hello All,

Once again having problems with Virtualmin 3.73 GPL backup/restore. Nothing I do seems to make it work.

I have a VPS running Virtualmin with no problems…well, no Webmin/Virtualmin problems! Virtualmin was installed using the install.sh script.

I created a full new style backup, and attempted to restore these to a brand new install.sh installation of Virtualmin on a new VPS at a different provider. I used the ssh backup to copy directly to the new system.

On the new system, when I try to restore, I get the following message:

Restoring backup for virtual server acorp.net .. Updating administration password and quotas .. ________________________________________ Restore failed : setquota: User acorp doesn't exist.

I am at a loss…am I supposed to create all the users myself? I thought that was the point of the backups.

What more information can I provide to assist someone in helping me out?

Thanks!

  • Acorp

www.acorp.net

the back up does create the user as far as I know, did you forget to enable a feature when making the backup or restore?

I left the “Backup all Features” radio button selected, and “Restore all Features” on the restore, but no love.

Any other thoughts? Or is it possible to recreate the Virtual users by manually copying some files over from the old VPS since I still have complete access to the old system?

Thanks!

  • Acorp

www.acorp.net

I have no means to test it at the moment, in this stage I would probably make a ticket so Jamie can give some insight

i have some problem! what is solution ?

Derick,

I fought with this error for so long and tried so many things that I don’t remember exactly what I did to finally make it work. I think the first thing I did was create the user that Virtualmin was complaining about via the linux shell using the ‘useradd’ command.

I then tried the import again, and think I got another error, which I also resolved via a shell command, then I think the import worked after that.

Hope this helps you.

  • Acorp

www.acorp.net