Virtualmin Remote API help

How do i set this up
I get this error
ERROR: You are not allowed to run remote commands

How do and what do i do to fix this error
I am running my website in cgi mode mod_cgi mod_perl mod_php5
I tried host.allow virtualmin: myserver,com :allow
I no its a permission thing but where do i fix them at (how to)
i am setting up billing app WHMCS with Virtualmin everything works perfect
except the Remote calls to the server
Any help would be most appreciated

----------------------Virtualmin api rules---------------------------------------
Remote API
The rules set forth in virtualmin documentation state
All remote calls must be made through the CGI /virtualserver/
remote.cgi. The full URL for this will be
.https://yourserver:10000/virtualserver/remote.cgi, where yourserver is the full hostname or IP address
of the system running Virtualmin.
This URL must be provided with at least one parameter named program, whose value must be the
name of the commandline
program to invoke, without the .pl extension. So a possible URL to request
would be: .https://yourserver:10000/virtualserver/remote.cgi?program=listdomains.
Because most commandline
programs require additional parameters, these must be included in the URL. Every CGI parameter is converted to a commandline
parameter, with the value of the parameter
appended if given. For example, to create a mail alias, you could invoke the URL:
To specify a parameter that does not have anything after it, just add a CGI parameter with no value. For
example, to list databases in detailed form, you could call:
Both GET and POST format HTTP requests can be used. If your Virtualmin server is not running in
SSL mode, use .http:// instead of https:// in the URL.


If you’re using WHMCS, it should handle the calls to Virtualmin’s API on it’s own, you shouldn’t need to dig down deep to get that working. If the calls WHMCS makes don’t work, that may mean there’s a configuration issue somewhere.

However, to make remote API calls, you’d also need to pass in authentication information for the Master Admin. An example of how to do that with wget is here:

wget–http-user=root --http-passwd=smeg ‘https://yourserver:10000/virtual-server/remote.cgi?program=list-domains

wget–http-user=root --http-passwd=smeg ‘https://yourserver:10000/virtual-server/remote.cgi?program=list-domains

That works on command line not in the server setup parameters in the whcms i need to no what settings to put into the server config >
Edit Server

Name server66


IP Address

for hostname i tryed >

Command line works perfect
but from whmcs i get ERROR: You are not allowed to run remote commands

thanks for fast reply

3 days need help with virtualmin 1 responce
Realy need someone whow understands how to fix my problem pointers ok

Hi digi,

Sorry to hear of your troubles. From my own personal experience I can tell you your best bet it to file a ticket.

As much as they would like to, Joe, Jamie, etc., can’t always follow everything that goes on in the forums, much less track it. If you file a support request ticket they’ll definitely respond.