Virtualmin (re) install fatal error

Hi,

I’m having an issue … My system is Ubuntu Linux 12.04 on VPS.
It all started when I noticed that some of my automated backups were failing. But all my hosted blogs where running fine.
I saw some update available on Webmin/Virtualmin information system. I tried to installed them and they all failed.
I decided to restart my VPS … after that apache failed to start, but I have been able to install all the updates.

So I tried to run webmin/virtualmin install.sh again and it failed with the error bellow. It seems that the script uninstalled apache but fail during the installation process.

I’m sorry, lots of error messages are in french but I can translate them if you need to :slight_smile:

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem:
php5 est déjà la plus récente version disponible. (the more recent available is already installed)
php5-cgi est déjà la plus récente version disponible.
php5-mysql est déjà la plus récente version disponible.
php-pear est déjà la plus récente version disponible.
apache2-suexec-custom est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
libapache2-mod-fcgid : Dépend: apache2.2-common mais ne sera pas installé
libapache2-mod-ruby : Dépend: apache2.2-common mais ne sera pas installé
libapache2-svn : Dépend: apache2.2-common mais ne sera pas installé

FATAL - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log

I tried “apt-get install -f”:

Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 72 non mis à jour.

And, “apt-get install apache2.2-common”
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
apache2.2-common : Dépend: apache2.2-bin (= 2.2.22-1ubuntu1.4) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

And, “apt-get install apache2.2-bin”:
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
apache2.2-bin est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 72 non mis à jour.

Thanks

It is NOT recommended to use the installer script on a system with Virtualmin already installed. Only use the installer on a fresh OS.

Normally I’d recommend to determine what caused the initial problem (i.e. the backups failing), before doing further steps. In your case though you already did and tried so many things that your system is probably quite messed up now.

I guess the easiest way would be to back up your Virtualmin domains, reinstall the VPS, put Virtualmin back on and restore the backups. Trying to troubleshoot your specific problems remotely at this point will be nearly impossible in my opinion.