Virtualmin processing messages are no longer progressive after recent update

Operating system: CentOS 7
OS version: Linux 3.10.0-1160.25.1.el7.x86_64 #1 SMP Wed Apr 28 21:49:45 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Installing updates, or performing multi-step operations output progressive messages to the browser. But after the lastest update to ver 1.974 these messages aren’t being streamed to the browser, but rather cached and fired in one shot after the operation is completed.

It’s just an observation and I think it happened after the most recent update.
Have you noticed this on your system?

Hi,

No, it works just fine for me. Have you tried clearing browser’s cache, trying incognito tab or another browser?

Tested on another device with Chrome browser that hasn’t visited this Virtualmin installation before. Same result.

I checked another server and it’s working progressively and nicely. It has Virtualmin 6.16 (like the other servers), but Webmin 1.973, unlike the others that have Webmin 1.974.

Strangely this server with the older version is not suggesting an update. yum update says there are no updates, even though Virtualmin’s repo is there (installed with /bin/sh install.sh --setup).

One final thought: I noticed this behavior happen on other servers (without Virtualmin) with nginx as it buffers the output and pushes it to the client at once when the PHP script is done. Could this issue be of a similar nature? I only use the standard LAMP installation of Virtualmin everywhere.

It should not be suggesting an update, because the Virtualmin repos currently offer 1.973. That’s intentional. If you have any Virtualmin systems suggesting an update beyond 1.973, that’s a problem (a Webmin system without Virtualmin would offer an update, and that’s correct). You either have another non-Virtualmin repo that has a newer Webmin (which you should not), or you’re hitting a buggy behavior caused by a root-level user that isn’t root and hasn’t been configured to not suggest upgrading based on incorrect information.

Edit: I just want to be clear that offering to update is unrelated to this problem, and also make it clear that the version of Webmin in webmin.com repos is often different from the version in Virtualmin.com repos, intentionally…and you should just trust us to provide the best-tested version of Webmin for use with Virtualmin.

1 Like

If you go to Webmin ⇾ Webmin Configuration: Advanced Options do you have Network buffer size in bytes set to default?

Perhaps, Webmin hasn’t been restarted correctly?

Thanks, @Joe. What do you think is the explanation that I have two other Virtualmin servers showing webmin version as 1.974? Could it be a bug? I always use the standard Virtualmin installation procedure. No fancy mods.
Virtualmin_webmin_versions

@Ilia, The buffer is set to the default (32K). I tried with smaller values, as little as 64 bytes, but the result didn’t change… except for once (using 128 byes), progressive output worked, and when I noticed it I went to change the value up & down to find the practical threshold, but it never worked again.

What else can I try?

P.s.: I’m connecting directly to the server. No proxy, no CDN, no VPN. Tested also with browser caching disabled (using Firefox).

I presume one installation uses regular login, like root and the other uses to login a root-capable user for which there is no /etc/webmin/webmin/username.acl file with disallow=upgrade option to prevent showing upgrade notifications on the dashboard.

What else can I try?

Simply add the following to /etc/webmin/config file and force refresh system information cached data using refresh button on the Dashboard:

nowebminup=1

All new installs in the future will get this option.