Virtualmin + Postfix - new Server Build using Import. Problem with Auto-forwarding.

History. My server was getting a little old so I have rebuilt a new server. My old server was a mail (Sendmail) + web server + router for the home network using Shorewall.

New server is using Postfix rather than Sendmail. This was the default mail program loaded during install of Suse Linux.

I used the Virtualmin “Import” that worked perfectly and re-created my web sites and populated Postfix correctly. Mail is arriving correctly and sending correctly.

But I can not get Postfix to use the “Auto-forwarding” of emails. It seems to be correct when I look at all the settings in Webmin but nothing gets auto-forwarded.

I’ve tried reading the documentation to sort this out but it is really confusing to me.

Does anyone know if there is a setting that I should be using? Or could point me in the right direction.

This might be related but I cannot get Joomla to send emails to me from a couple of sites but strangely a program called Zen Photo works perfectly. Very confusing.

Any help would be gratefully received.



Can you describe how you’re setting up forwarding? There’s a few different ways to do that, knowing how you’re doing it on your system there would help in troubleshooting it.

As far as your Joomla emails go – what you might want to do is take a peek in the mail logs whenever an email should be sent, those may show you what’s going on. The mail logs are in either /var/log/maillog, or /var/log/mail.log, depending on your distro.



Thanks for the reply. The Joomla sending email is now seemingly fully functioning. So that has dropped off the bottom of my list!!

(Virtualmin did the setup and it was all working on Sendmail)

I’ve tried a couple approaches that I found on the web. (Using the .forward file in the users home directory / editing the “Virtual File”). I have successfully managed to get a forward working providing it is to an email address hosted on my server, I had to hand edit the “Virtual” file as (so it seems) everything that Virtualmin put in the aliases file as forwards does not seem to work at all .

Virtual File << So that worked all OK,
but if I try << This did work if the email was sent from my internal network but not if it was sent from “say”

I’ve hunted the log files and nothing really stands out except this message, which I doubt is related to the forwarding issue.

May 18 16:44:12 apache-web-server dovecot: POP3(nigel.twin-peaks-video): fchown(/home/tpv/homes/nigel/mail/.imap/INBOX/dovecot.index.tmp, -1, 0(root)) failed: Operation not permitted (egid=1000(twin-peaks-video), group based on /var/mail/nigel.twin-peaks-video)

It’s stuff like this that totally confuses me :slight_smile: , especially as everything was setup by Virtualmin’s Restore option.


Well, it’s possible that you’re seeing an issue in moving from Sendmail to Postfix.

I’m not sure that Virtualmin supports such a change, but it might, I’ll have to ask Jamie :slight_smile:

What distro are you using?

And did you use the to perform the Virtualmin installation?

As a whole though, you’re saying the only thing that isn’t working is forwarding? You’re otherwise able to both send and receive emails without a problem?


SuSE Linux 11.4
I downloaded Virtualmin and then used Webmin’s “Install from local file” option.

As a whole though, you’re saying the only thing that isn’t working is forwarding? >> Correct

You’re otherwise able to both send and receive emails without a problem? Yes.

I’m not sure what that warning means (other message) but everything seems to be working correctly and I use Thunderbird and the Wifey uses Outlook. Not had a chance to test Squirrelmail yet on the “outside” but it’s working on my home machine.

If what I did was bad JuJu (sendmail to postfix) what would be the best thing to do? (and I don’t really want to have to delete all my virtual servers and start again :slight_smile: )

BTW - Thank you Eric for this help.

Discovered that I needed to make sure the ip address of the server was also included in the $relay_domains setting.

Changed it from $mydestination to $mynetworks and all works.

Checked the site using an email relay checker and all is good.