Virtualmin/Postfix error.

I get the following error in both the free and commercial version on Fedora Core 4.

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configurated, and that quotas are active …

  No virtual domains file was found in your Postfix configuration. Maybe no virtual domain map has been defined.

… your system is not ready for use by Virtualmin.

Postfix 2.2.2
Webmin 1.230

Thanks for any help.

Hey Aaron,

This one is easy to fix, but I’m surprised it happened in Virtualmin Professional. The installer is supposed to set this up for you. Was this an existing Virtualmin GPL system? There are many known issues with upgrading to Professional at this point (if your mail server is postfix, the issues are all easily fixable).

Anyway to workaround it:

Browse to Servers:Postfix Configuration:Virtual Domains

In the "Domain mapping lookup tables" field, enter: "hash:/etc/postfix/virtual" without the quotes.

Save it.

Browse to Virtualmin Virtual Servers and re-check your configuration. Holler if this fails to resolve this issue.

This isn’t working for me… it gives this error when I put in that lookup table and hit apply:

Failed to save options : Failed to regenerate table /etc/postfix/virtual: postmap: warning: valid_hostname: numeric hostname: postmap: warning: valid_hostname: numeric hostname: postmap: warning: valid_hostname: numeric hostname: 168.1.1

Any ideas?

Hey Brett,

This is strange. Your system doesn’t have a fully qualified hostname, and yet the installer didn’t catch that fact. The system must have a fully qualified hostname (like, and an IP address or localhost.localdomain won’t do. This is a requirement of Postfix (and any mailserver, really…Postfix is just very particular about making sure you have one before it will do anything).

I’d better spend some time with the installer to be sure this check actually works for all cases.

After you give your box a real hostname, then solution I gave above should work fine.

Thank you, this fixed the problem

In case it will help you, instead of my actual my hostname, I had put in my router IP ( don’t even know what I was thinking… )

When i apply the hash info provided within the postfix config i get this error…Anyone have any ideas?

Failed to save options : Failed to regenerate table /etc/postfix/virtual: /usr/sbin/postmap: /usr/lib/mysql/ no version information available (required by /usr/sbin/postmap)