Virtualmin port:10000 and google chrome issue

Hello all,

Freshly install Virtualmin and I have one domain with Let’sEncrypt SSL.

I did copy the same Certificate to Webmin as default and now google chrome showing me an error.
Screen Shot 2020-04-23 at 5.39.40 AM

When I checked in Safari it is using SSL
Screen Shot 2020-04-23 at 5.47.38 AM

How can I fix this issue? I don’t use safari I’m with google chrome so it is much easier for me if I could get this fixed.


Can you open the certificate safari is showing and check it is the Let’s Encrypt certificate and not a self signed certificate generated by Vmin.

Does the certificate include the domain name you are accessing? The error appears to suggest the certificate cannot find the name of your domain.

whats the domain name? I would rather like to see https link, check in browser what ssl cert is in use, in chrome click on address bar where its said not secured or where is padlock this will tell you what ssl cert you are using

@GeoffatMM @unborn

It appears to be that Virtualmin using my domain certificate from Let’s Encrypt.

Is there a way to use a new Let’s Encrypt certificate only for Virtualmin and not use the certificate which I got for my domain.

Yes. By default it only uses the cert you requested for the virtual server. But if you copy that cert to webmin and usermin, then you might get issues.

Yes correct. i did copy that cert to webmin. so is there a way to resolve this issue and get virtualmin/webmin a new cert from Let’s Encrypt?

Simply go to the virtual server which contains the domain for webpanel and make sure to include that domain (if it isnt already) in the request.
Copy that certificate back to webmin /etc.

@DrCarsonBeckett I’m sorry I don’t really understand what you said can explain it to me with more details.

Thank you

If your virtualmin domain is, for example, on port 10000 and the default domain is on port 80 / 443 then you could get a Let’s Encrypt SSL certificate for that domain via Virtualmin | Server Configuration | SSL Certificate. After the certificate has been successfully applied, you should be able to access (on port 443) and see a lock symbol in the address bar of the browser.

The next step is to apply the same certificate on the webmin service (as well as Dovecot, Postfix etc.) and this is done easily via:

You must now click the “Copy to Webmin” button and the buttons below it, one by one, till the screen looks like:

At this point you will have the default domain and Webmin / Virtualmin using the same SSL certificate without error.

Pro Tip: when using the same domain name for default domain and Webmin / Virtualmin, uncheck the box for “Mail for domain enabled” under Virtualmin | Edit Virtual Server | Enabled Features to avoid lots of warnings in the mail log.

Thank you for your reply really appreciate it.

Unfortunately, my control panel on port 10000 is not the same name as my main domain. I have already done the above step earlier and that is why I’m getting error because there are two different names.

Since your control panel on port 1000 (your hostname) is not the same as the default domain you have used in Virtualmin, you should not have followed the procedure that I have described in my earlier message.

Here is what you should have done and should now do to get Webmin / Virtualmin to show sans error in a browser:

  • Webmin | Webmin Configuration | SSL Encryption
  • Generate the Let’s Encrypt Certificate for the hostname (select the appropriate option for “Website root directory for validation file”)
  • Apply this certificate to Dovecot, Postfix etc.
1 Like

Get this error from Let’sEncrypt
Use DNS domains for validation
Requesting a new certificate for, using DNS validation …

… request failed : Neither DNS zone or any of its sub-domains exist on this system

Ignore my other reply.

Thank you so much I finally managed to get the cert.

Screen Shot 2020-04-24 at 12.11.11 PM

Finally now my connection is secure no more google chrome error. :slight_smile:

Once again thank you all so much.
Stay Safe and Bless you All :slight_smile:

That’s wonderful @anthonyinit2012. If you could mark the answer that I had provided as the solution, it might help others who have similar problems find the information they seek.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.