Virtualmin not working - only default web server is showing

Hi all

First off I’m sorry but this is one of the many virtual host issues that has been discussed many time before but I’ve tried all the various options but can’t seem to get it working, hopefully someone out there could point me in the right direction.

I’m running CenOS 5.8 fresh clean install. I’m running behind a firewall

Currently I have two virtual servers: Both are pointing to the external address

Virtual webmin module configurations

Default virtual server IP address: from network interface

Default IP address for DNS records: external IP

Apache reports:

Default server is listening on any address and any port

both virtual servers are on the external IP at port 80

Can anyone help and point me what I should be changing?

Thanks in Advance



So just to clarify your setup there – is your server behind a NAT router of some sort, meaning that your server has an internal IP address?

If that’s the case – the Apache config for your domains would need to have them setup on your internal IP address.

So when looking at /etc/httpd/conf/httpd.conf, you’ll see a number of “VirtualHost” blocks towards the bottom, containing the config for your domains. The IP address in the VirtualHost section needs to be your internal IP address, not your external IP address.


Hi Eric

Thanks for the reply: Yes my server is behind a NAT router, its on an internal 192.168 network. I know how to do it manually in httpd.conf but I was trying to get virualmin setup correctly . If I point virtualmin to the internal ip, virtualmin complains.

You need to change this in Virtualmin - System Settings - Virtualmin Configuration - Networking
Default virtual server IP address: 192.168.xx.xx (your LAN IP)
Default IP address for DNS records: external IP


that seems to do the trick, thanks a lot guys :slight_smile: