virtualmin not updating packages

When I login to virtualmin the start screen informs me: 9 updates to Virtualmin packages are available.

But when I click "Install All Updates Now" or "Use the Virtualmin Package Updates module to install them selectively" I get stuck in "read ..." (my IP) at the bottom of the browser, or get stuck in Now updating proftpd … forever.

(I still have the issue that Usermin is stalling at least once a day, now just Usermin though, Webmin never stalls. I get the feeling my VPS is "sick" but worry a bit more about a re-install with 5 domains running incl. email and some mysql connections)

one more info: when I do any YUM via SSH with putty I get stuck in "Loading "fastestmirror" plugin"

Seems it’s not related to Virtualmin in any way, I still need some ideas how to fix that, or better, the root cause.

Well, these two issues are definitely related :slight_smile:

Can you log in over SSH, and type "yum update", and then paste any output you receive into this thread?

Also, what does this show:

ls /etc/yum.repos.d/

one more info: when I do any YUM via SSH with putty I get stuck in "Loading "fastestmirror" plugin"

This makes me think you don’t have working DNS. Obviously, a lot of stuff will not work if you don’t have working DNS service. Check on that first.

Here are my repos after a fresh VPS restart:

[code:1]# ls /etc/yum.repos.d/
CentOS-Base.repo epel-testing.repo virtualmin.repo
CentOS-Media.repo epel.repo

Unusual: virtualmin.repo was in red. What does that mean?

I think the “epel” ones shouldn’t be there, or? How do I remove them?

BIND/named is working.

"yum update" worked and it updated. Here is the output anyway:

[code:1]# yum update
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile

  • epel:
  • virtualmin:
  • base:
  • updates:
  • virtualmin-universal:
  • addons:
  • extras:
    epel 100% |=========================| 2.1 kB 00:00
    virtualmin 100% |=========================| 951 B 00:00
    base 100% |=========================| 1.1 kB 00:00
    updates 100% |=========================| 951 B 00:00
    virtualmin-universal 100% |=========================| 951 B 00:00
    addons 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    Setting up Update Process
    Resolving Dependencies
    –> Running transaction check
    —> Package clamav.i386 0:0.94.2-1.el5 set to be updated
    —> Package proftpd.i386 0:1.3.1-8.el5 set to be updated
    —> Package wbm-php-pear.noarch 2:1.4-1 set to be updated
    —> Package scponly.i386 0:4.8-1.el5 set to be updated
    —> Package rubygems.noarch 0:1.3.1-1.el5 set to be updated
    —> Package wbm-virtualmin-htpasswd.noarch 2:1.9-1 set to be updated
    —> Package krb5-devel.i386 0:1.6.1-25.el5_2.2 set to be updated
    —> Package ust-virtual-server-theme.noarch 2:6.6-1 set to be updated
    —> Package wbm-ruby-gems.noarch 2:1.3-1 set to be updated
    —> Package clamav-server.i386 0:0.94.2-1.el5 set to be updated
    —> Package clamav-server-sysv.i386 0:0.94.2-1.el5 set to be updated
    —> Package clamav-data.i386 0:0.94.2-1.el5 set to be updated
    —> Package clamav-update.i386 0:0.94.2-1.el5 set to be updated
    —> Package epel-release.noarch 0:5-3 set to be updated
    —> Package clamav-lib.i386 0:0.94.2-1.el5 set to be updated
    —> Package wbt-virtual-server-theme.noarch 2:6.6-1 set to be updated
    —> Package wbm-security-updates.noarch 2:3.2-1 set to be updated
    —> Package wbm-virtual-server.noarch 0:3.65.gpl-1 set to be updated
    —> Package krb5-libs.i386 0:1.6.1-25.el5_2.2 set to be updated
    —> Package dbus.i386 0:1.0.0-7.el5_2.1 set to be updated
    —> Package clamav-filesystem.i386 0:0.94.2-1.el5 set to be updated
    –> Finished Dependency Resolution

Dependencies Resolved

Package Arch Version Repository Size

clamav i386 0.94.2-1.el5 epel 677 k
clamav-data i386 0.94.2-1.el5 epel 18 M
clamav-filesystem i386 0.94.2-1.el5 epel 18 k
clamav-lib i386 0.94.2-1.el5 epel 339 k
clamav-server i386 0.94.2-1.el5 epel 63 k
clamav-server-sysv i386 0.94.2-1.el5 epel 18 k
clamav-update i386 0.94.2-1.el5 epel 69 k
dbus i386 1.0.0-7.el5_2.1 updates 469 k
epel-release noarch 5-3 epel 12 k
krb5-devel i386 1.6.1-25.el5_2.2 updates 1.9 M
krb5-libs i386 1.6.1-25.el5_2.2 updates 658 k
proftpd i386 1.3.1-8.el5 epel 1.7 M
rubygems noarch 1.3.1-1.el5 epel 177 k
scponly i386 4.8-1.el5 epel 33 k
ust-virtual-server-theme noarch 2:6.6-1 virtualmin-universal 2.2 M
wbm-php-pear noarch 2:1.4-1 virtualmin-universal 14 k
wbm-ruby-gems noarch 2:1.3-1 virtualmin-universal 14 k
wbm-security-updates noarch 2:3.2-1 virtualmin-universal 29 k
wbm-virtual-server noarch 3.65.gpl-1 virtualmin-universal 1.2 M
wbm-virtualmin-htpasswd noarch 2:1.9-1 virtualmin-universal 15 k
wbt-virtual-server-theme noarch 2:6.6-1 virtualmin-universal 2.2 M

Transaction Summary

Install 0 Package(s)
Update 21 Package(s)
Remove 0 Package(s)

Total download size: 30 M
Is this ok [y/N]: y
Downloading Packages:
(1/20): clamav-filesystem 100% |=========================| 18 kB 00:00
(2/20): dbus-1.0.0-7.el5_ 100% |=========================| 469 kB 00:00
(3/20): krb5-libs-1.6.1-2 100% |=========================| 658 kB 00:00
(4/20): wbm-virtual-serve 100% |=========================| 1.2 MB 00:00
(5/20): wbm-security-upda 100% |=========================| 29 kB 00:00
(6/20): wbt-virtual-serve 100% |=========================| 2.2 MB 00:01
(7/20): clamav-lib-0.94.2 100% |=========================| 339 kB 00:00
(8/20): epel-release-5-3. 100% |=========================| 12 kB 00:00
(9/20): clamav-update-0.9 100% |=========================| 69 kB 00:00
(10/20): clamav-data-0.94 100% |=========================| 18 MB 00:15
(11/20): clamav-server-sy 100% |=========================| 18 kB 00:00
(12/20): clamav-server-0. 100% |=========================| 63 kB 00:00
(13/20): wbm-ruby-gems-1. 100% |=========================| 14 kB 00:00
(14/20): ust-virtual-serv 100% |=========================| 2.2 MB 00:01
(15/20): krb5-devel-1.6.1 100% |=========================| 1.9 MB 00:00
(16/20): wbm-virtualmin-h 100% |=========================| 15 kB 00:00
(17/20): rubygems-1.3.1-1 100% |=========================| 177 kB 00:00
(18/20): scponly-4.8-1.el 100% |=========================| 33 kB 00:00
(19/20): wbm-php-pear-1.4 100% |=========================| 14 kB 00:00
(20/20): clamav-0.94.2-1. 100% |=========================| 677 kB 00:00

…and I still have stalling problems with BIND, Postfix, Dovecot, Usermin, and seldom Webmin. I think it’s all related. I probably did something wrong with some unneeded installations or unhealthy repos.

Well, first, you can remove a repo by going into /etc/yum.repos.d/, editing any of the repos, and setting "enabled" to "0".

However, in the above output, notice the "killed" at the end.

I think you’re still having issues with not having enough resources to run the services you’re hoping to run.

Most likely, the above was killed by the Linux process management because it ran out of memory.

I think we went over this before, but what is the output of the command "free"? One of the things is to verify that you have swap enabled, and have enough of it.

EPEL shouldn’t cause any problems. There might be a wee bit of overlap, but the EPEL packages should be compatible with ours. But, if you don’t need packages from EPEL, there’s no harm in disabling it (but, if you aren’t sure you don’t have some packages installed from there, you’ll want to keep it so that updates will continue to be available–security demands that any package you have installed must be update-able easily).

But, Eric’s right…It seems like maybe you have other problems there, if yum can’t run to completion. It’s not a yum configuration issue.

Here is my free:

[code:1]# free
total used free shared buffers cached
Mem: 292864 70812 222052 0 0 0
-/+ buffers/cache: 70812 222052
Swap: 0 0 0[/code:1]

I check FREE quite often and can’t see anything unusual. I still have stalling issued, just right now when I checked BIND/named, Postfix, Dovecot, Webmin and Usermin where down and I had to start them manually.

For memory saving, I did some of the saving tricks you linked me to last time. I am not sure about the "enable swap" - how to check on that?

I removed the EPEL repos anyway. In fact, I don’t need anything special on my VPS. I run webmin/virtualmin out of the box. I may did install something I don’t need in my “very new to VPS phase”.

I would say my VPS is running very low activity. I have 5 domains in it. There are 3 services with mysql connection, 1 forum, 1 online shop, 1 project software. All are very low activity with maybe compined less then 10 actions a day.

Ahh, but you don’t have any swap enabled there.

So, while things may look reasonable now – during a spike in usage (such as when you run "yum"), that could quickly chew through the remainder of your RAM.

I’d make sure you have some swap space available on your machine, that may go a long way to solving the issues you’ve been seeing.

I'd make sure you have some swap space available on your machine, that may go a long way to solving the issues you've been seeing.

I am on a hosted VPS with Virtuozzo as interface and with limited access to the actual server. How do I do that?

Well, I don’t really know enough about your environment, server setup, and provider in order to make the best recommendation on how to setup swap space on your system there.

What I would do is contact your VPS provider, and tell them you want to setup at least 512MB of Swap, and they should be able to point you in the right direction.

I will check with them.

My next message is probably about re-installing everything…