virtualmin navigation/menu not working

Hello,
I logged into my virtualmin panel today/now and i can not manage my domain because the left side menu isn’t working. All i see is the domain dropdown list, everything else that should be below it isn’t working/showing. I get the following error message:

Content-type: text/html; Charset=iso-8859-1
Module Index
Error

Failed to query Postfix config command to get the current value of parameter config_directory:

I have attached a picture of it for your review. i will very much appreciate a help to have this fixed.

Hello,

What is the output of this command:

find /etc/webmin/ | xargs grep postfix_config_command

On my system, it is:

/etc/webmin/postfix/config:postfix_config_command=/usr/sbin/postconf

At which point, if I type:

ls -l /usr/sbin/postconf

I get:

-rwxr-xr-x 1 root root 63660 Sep 9 19:55 /usr/sbin/postconf

So I’m curious what your system shows there, and if the command it’s trying to use exists.

Thanks,
-Eric

Hi andrey, i don’t understand what you your reply. could u pls be more clear?

Hello –

Log into your server over SSH, and run this command:

find /etc/webmin/ | xargs grep postfix_config_command

And paste the output into the forum here.

Thanks!
-Eric

hello andreycheck,
here is the SSH result of the command:

/etc/webmin/postfix/config:postfix_config_command=/usr/sbin/postconf

Okay, that looks good!

Now the second step – what is the output of this command:

/usr/sbin/postconf | grep command_directory

Thanks,
-Eric

hi andreychek,
here is the result for the command:
command_directory = /usr/sbin

The goodnews is that nav menu is back. I rebooted the server from SSH and after which i logged back in into virtualmin and the virtualmin navigation menu started showing.

The only problem now is the FTP details of my sites are no longer working. It was working fine until i started experiencing that same navigation problem. I can not login into my site FTP details. i keep getting the following error: can’t exterblish connection.

And also mysite can not connect to the MySQL database again which was working fine before. i got this error: Mysql error:
Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2)

Are the FTP and MySQL services started?

If you log into Virtualmin, click "System Information", then click the "Status" button in the middle of the screen.

Verify that "ProFTPd FTP Server" and "MySQL Database Server" are both running.
-Eric

andreychek, thanks for your help so far.
I have checked. ProFTPd FTP Server" and "MySQL Database Server" are both running fine.

I am still not able to login to FTP

Do you have any ideas as to anything that may have changed just before you started seeing those problems?

The error you’re seeing, “Can’t establish connection”, tells me that either FTP isn’t running properly, or perhaps a firewall is blocking you.

Did you recently install a firewall on that server?

On the server itself, can you log into SSH and run these commands:

  1. netstat -an | grep :21
  2. iptables -L -n

Thanks,
-Eric

hi, all i did was click on feature update button i saw on virtualmin when i logged in. normally feature update where usually below sysmtems information when one login. but this update button wa the only this on the page this time. nothing else was showing on virtualmin when i login so i clickd on the update button.

Thats all i did before this problem started. below are the result for me commands

  1. netstat -an | grep :21
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN

  2. iptables -L -n
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT udp – 0.0.0.0/0 0.0.0.0/0 udp dpt:20
    ACCEPT udp – 0.0.0.0/0 0.0.0.0/0 udp dpt:21
    ACCEPT udp – 0.0.0.0/0 0.0.0.0/0 udp dpt:53
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:20000
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:10000
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:443
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:80
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:993
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:143
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:995
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:110
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:20
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:21
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:53
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:25
    ACCEPT tcp – 0.0.0.0/0 0.0.0.0/0 tcp dpt:22

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Yeah, I’m not seeing any reason why your server wouldn’t be accepting connections.

Perhaps one of the log files might have some information in it.

Barring that, the only other thing I can offer is that perhaps I could log in and take a look myself.

If you want me to take a look, you’re welcome to send me login details for both root, and a user, to eric@virtualmin.com.

Thanks,
-Eric

Hi Eric,
I just emailed you my server details. the email should come from eugeneazuka@gmail.com

Hi there,

So, I have good news, and bad news :slight_smile:

The good news is that I was able to log into FTP just fine using the information you gave me. It was actually quite speedy!

Which I suppose is bad news, in that I’m not sure why it isn’t working for you.

I’d normally suggest trying both Active and Passive FTP modes, but both of them worked well for me, so that’s unlikely to be the problem.

Is it possible it’s a problem with your FTP client, or maybe even your ISP?
-Eric

well thank you very much. let me assume it’s the ISP though it’s the isp i’ve always been using. i also used it to login ealier. i was even logged-in before this problem started. as regards the FTP client. i don;t think so because i have tried 2 FTP clients (CuteFTP and FileZilla) both were working and suddenly stoped so i guess it might be my ISP.

For now i have used the WebFTP in Webmin to upload things i wanted to upload. Thank you very much.

I have one final question though. How can i have a domain/virtual server point to a folder inside of public_html instead of public_html/

i have a directory called community created inside the public_html (public_html/community) and i want my domain to point to the community directory instead of stoping at public_html/

How can i do this? i have tried ediing the domain home directory but not reflecting

Regarding FTP – I’ve also seen some routers have seemingly random problems not unlike this. You might consider turning your router off and back on to see if it makes a difference.

Regarding the domain pointing to a directory – it sounds like you want one of the following options, each of which is in Services -> Configure Website.

If you want to redirect from public_html to community, then you can go into "Aliases and Redirects", and set a "Permanent URL redirect" from / to http://yourdomain.com/community/ .

If you’re just looking to change the document root (ie, you want to restrict all web traffic to directories within “community”, you can go into -> Document Options and change “Document root directory”.

Then be sure to hit “Apply Changes”, which restarts Apache, when you’re done.

Hi eric,
I’m not using a router. i;m just browing from my laptop.

as regards the domain. i have made the changes inside ->Document Options -> Document root directory to /home/username/public_html/community/

when i visit mydomain.com, it’s still not showing the content of the community directory.

It looks like Virtualmin wasn’t able to apply the configuration changes you made due to a syntax error in the httpd.conf file:

/etc/init.d/httpd reload

Reloading httpd: not reloading due to configuration syntax error

We can see the exact error by typing:

httpd -t

Syntax error on line 1032 of /etc/httpd/conf/httpd.conf:
Redirect to non-URL

So on line 1032, we see:

RedirectPermanent yourdomain.com "yourdomain.com/community/"

That should actually read something like:

RedirectPermanent yourdomain.com "http://yourdomain.com/community/"

It’s probably a bug that Virtualmin allows that to be entered without the “http://” on the front – but if you manually add that, you should be in good shape.

Test the configuration again, and if it’s okay, go ahead and restart Apache.

I can fix it if you want, but I’m reluctant to change your httpd.conf without your permission!
-Eric

Pls Eric,
I will very much appreciate if you can help me fix it. pls you have my very full permission.

please.

Okay, all set!

If you go to "http://yourdomain.com", it works.

If you get a blank screen, it’s a problem with your browser cache, hold down shift and click reload, and it will work.

Let me know if that goes the trick. Thanks,
-Eric