virtualmin loading slowly

Often it seems to be taking a long time for my virtualmin to load, and sometimes I have to refresh it several times before it comes up.

The statusbar on my browser (IE7) usually says "waiting for (myip):10000/Sec-updates/index.cgi?mode=new"

I have changed my virtualmin port to a different one, and 10000 is firewalled. Would that be the problem? Should virtualmin have reset the port for that url when I changed the virtualmin port?

Hrm, I’m not really sure about that one.

First, you might try restarting Webmin – you can do so by logging in over SSH, and typing:

/etc/init.d/webmin restart

Also, are you seeing any messages in Webmin’s error log? You may want to take a look at /var/webmin/miniserv.error and see if there’s any errors in there.
-Eric

ohhh, lots of info in there…

Looks like it logs php errors and everything (had lots of those after transferring my php4 sites over). I hope it cleans itself out every once in a while, otherwise it’s gonna get very big!

It’s complaining about me accessing the site by https://ipaddress:port and wants me to use http://hostname:port instead.

and… doing it by hostname it’s coming up much, much faster :slight_smile:

I was under the impression that it was designed to be accessed from the ip, no? Doesn’t matter, I can do this just as easy.

The only other thing added to the log when I restarted webmin was the authen::pam error, which, according to other threads is not a problem.

Thanks again Eric. Your help has been invaluable and I am learning a lot from you!

Chris

It's complaining about me accessing the site by https://ipaddress:port and wants me to use http://hostname:port instead.

and… doing it by hostname it’s coming up much, much faster :slight_smile:

I was under the impression that it was designed to be accessed from the ip, no? Doesn’t matter, I can do this just as easy.

IP and hostname are irrelevant (unless you’re forcing it to connect over a troubled connection…say you’re on a private network and forcing an external connection or vice versa, and there’s something wrong with that connection).

So, if it’s fast in one way, and not another, you’ve got some sort of network problem to contend with…though I’m not sure what. Could be DNS if you’ve configured Webmin to resolve client IPs to names (this isn’t generally recommended, except on fast local networks).

The only other thing added to the log when I restarted webmin was the authen::pam error, which, according to other threads is not a problem.

It’s definitely not a problem. That’s why it says, “Continuing without PAM”, or whatever right after, rather than something like, “OMG! I can’t go on without PAM in my life!”. :wink:

https://ipaddress:port and wants me to use http://hostname:port instead.

Oh, there’s another difference between these two. https vs http? Is that a typo, or is that actually what’s in the error?

If so, you’ve got SSL misconfigured or turned off (in which case it shouldn’t be “slow”, it should be, “doesn’t work at all”).

Yes, a typo, sorry.

I am getting this in the miniserv log:

[21/May/2009:08:42:00 -0400] [87.106.134.34] Bad Request : This web server is running in SSL mode. Try the URL <a href=‘https://jessica.mysite.com:10000/’>https://jessica.andrews.com:10000/</a> instead.<br>

and I think it was in my apache logs that I saw something saying that the host name should not be in ssl.

I had put the hostname in ssl mode, and have been using that to access virtualmin, but I guess that’s not the way it’s supposed to work.

So I guess I need to take ssl off the host name… as that’s what’s causing the server to run in ssl mode, correct?

Howdy,

So I guess I need to take ssl off the host name... as that's what's causing the server to run in ssl mode, correct?

Hmmm… I’m not entirely sure I followed what you said that, but two comments:

  1. To enable SSL mode in Webmin/Virtualmin, you can go into Webmin -> Webmin -> Webmin Configuration -> SSL Encryption. Though it looks like in your case, this is already enabled.

  2. To access Webmin/Virtualmin using SSL encryption, it’s just a matter of using the https:// when entering the URL in your browser, rather than just “http://” (you want to make sure you have the ‘s’ in there).