Virtualmin left bar not shown

So I have a CentOS 7.x server running the latest version (from the official repositories) of virtualmin/webmin. I’ve recently upgraded to MariaDB-10.3.24 (using the official MariaDB repo). I’ve ran the mysql_upgrade command and restarted the mariadb service. I can login to webmin, but for some reason, while trying to access virtualmin and the virtual servers, the left sidebar is not shown. I can login as root via the mysql command using a shell console. I’ve tried to change the mysql root password using webmin interface. I’ve also added these in /etc/my.cnf.d/server.conf:

I tried to check for errors on the server but I can’t find any. I’ve also replaced on the server with the latest version of the same file downloaded from the official github repo for virtualmin. Nothing seems to work.

I’ve attached a screenshot as well.

The websites from the server work just fine, the issue is only with the virtualmin not displaying options for the virtual servers, so basically now changes can be performed from the web UI

Any help would be really appreciated!


You would need to check on account level permissions (ACLs) -

… make sure that Virtualmin Virtual Servers is added for current user, among other modules and click Save at the bottom of the page (anyway to update). Then come back, click on Virtualmin Virtual Servers and click to Reset To Full Access button:

This, unfortunately, we cannot support, as we don’t recommend doing it, because we are not sure, if it would work as expected. It might though but might not as well. We can only recommend packages that we test, which are distributed by default with your OS distro.

On the other hand, I don’t see how upgrading MariaDB could possibly cause the issue you’re reporting. It must be something else that you have done.

Apparently now I got a new issue which might be the reason left bar is not showing.

Now re-checking your Virtualmin license …
… a problem was detected : An error occurred checking the licence : Invalid host or serial number

[root@webserver yum.repos.d]# cat /etc/virtualmin-license

I do not have a paid license and that’s the only change I’ve done on the server. Removed the default mariadb-server which was v5.5 and installed MariaDB-10.3.24

I tried restarting webmin but I still get this license error message…

Virtualmin does not rely on MySQL/Mariadb. The problem with Virtualmin access is unrelated to your database upgrade.

There was, months ago, an accidental merge of Pro into the GPL package repository. That’s the only thing I can think of that would cause the license error you see. Upgrade to the current version to resolve it, if so.

So, to be clear: Mariadb is a red herring. There may be problems with it, but it would not cause the issues you’re seeing in Virtualmin. I’m not sure what would do that…maybe removing access for the user, somehow. It used to be possible to break the root user by assigning ownership of a domain to root. This is a nonsensical thing to do, but Virtualmin used to not prevent you from doing it…but it has prevented it for years. You could probably still do it if you really worked at it, but it wouldn’t happen accidentally, I don’t think.

I’m kinda at a loss for how you’ve gotten where you are. But, it’s definitely not the database. We simply don’t store anything in the database, unless you explicitly configure Virtualmin to do so (you’d know if you’d done that, as it is a very complicated process).

So I’ve logged out, logged in and I’m getting this (see screenshot). I’ve ran re-check and refresh server configuration and after that completed, I’m able to see the left sidebar while accessing Virtualmin but I can’t get rid of that license message.

Apparently, after reinstalling virtualmin and webmin packages using yum -y reinstall virtualmin webmin, the issue is gone. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.